PROBLEME & LÖSUNGEN für Glide Spiele

  • Hallo,


    ich ergänze mal Daywhite_81's Glidespiele-Kompatibilitätsliste ein bisschen.
    Alle folgenden Games funktionieren bei mir 100% sicher mit den jeweils dazugeschriebenen Voodookarten.
    Keine Erinnnerungen von Anno dazumal.
    Das heisst aber nicht, dass sie mit anderen Voodoos nicht laufen, ausser ich habe das explizit dazugeschrieben.
    Ich werde das alles bei Gelegenheit auch noch in die Glidespieleliste implementieren.


    Extreme Assault - V5
    Gex 3D Enter The Gecko - V5
    Incoming - V2
    Incubation - V1, V2 (mit V3-5 funktioniert es nicht)
    Pandemonium 2 - V5
    Schleichfahrt (+Glidepatch) - V1 only (laut Patch-Readme auch V2-kompatibel, ist mir aber bisher nicht geglückt. Mit Rush laut einem anderen User hier zu langsam)
    Uprising - V5
    Unreal - V5
    Wing Commander Prophecy - V5


    Beste Grüße =)

    Einmal editiert, zuletzt von 3dfxxxxx ()

  • Ich werde deine Liste meiner hinzufügen, aber wie bekommst du bei Incoming Glide???
    Das läuft immer nur mit Direct3D bei mir.


    EDIT: Auch hier wird geschrieben das es nur ein DX6 Spiel ist ohne Glide
    http://www.zeus-software.com/forum/viewtopic.php?t=409

    3dfx SYSTEME (Silent/low Noise) Windows 98 SE:

    QDI Legend V2200 AGP +Diamond Monster 3D +Videologic Apocalypse 3Dx | ASUS P2B-B | PII 450 | 128MB | 32GB CF
    Matrox G400 MAX +Matrox m3D +Orchid Righteous 3D² SLI | ASUS P3B-F | PIII 1100 | 256MB | 8GB CF
    Voodoo 5 5500 AGP | ASUS TUSL2-M | PIII-S 1400 | 256MB | 120GB SSD
    Voodoo 5 5500 AGP | EPoX EP-8K5A3+ | AthlonXP 3000+ | 512MB | 16GB CF |

    Einmal editiert, zuletzt von Daywhite_81 ()

  • Okay sorry,


    dann streich es raus.
    Ist wohl doch nur eine "Erinnerung", da ich das Spiel voriges Jahr deinstalliert habe.
    Ich bilde mir zwar ein den 3dfx-Splashscreen vor diesem Spiel gesehen zu haben, womöglich ist das aber eine falsche "Erinnerung".
    Sorry nochmal.
    Die restlichen Games habe ich aber noch installiert, die müssten passen.


    Beste Grüße

  • Tolle Sache das! Mich würde nämlich Tomb Raider interessieren, das will und will nicht mit meinen V2's.
    Das es aber geht weiß ich, ich hatte früher nie eine V1, sondern nur V2 und ich hab es mit einem Patch spielen können. Oder es war doch der Mystique-Patch....ich weiß es einfach nicht mehr?


    Ich habe das Spiel heute mit einer V2 starten probiert.
    Also ich denke das auf jeden Fall der V1 patch genommen werden muss.
    Damit startete das Spiel jedoch ohne Bild und nur Musik.
    Mit dem Rush patch ist es immer abgestürzt.


    Den Texturspeicher per Treiber auf 2 MB zu begrenzen hat nicht geholfen.
    Mal schaun was noch möglich ist.


    Nachtrag:
    kompatibilität für DOS Spiele und Voodoo 2 (VOGONS Forum)


    Hier sind viele Einträge zu DOS Spielen mit Voodoo2 und sogar 3 und 5.


    Nachtrag 2: Anscheinend kann TR mit beiden Patches laufen.
    Für den Rush Patch muss laut Vogons postings eine glide.ovl im Spieleordner sein und für den V1 patch muss eine angepasste Batch Datei erstellt werden.

    3dfx SYSTEME (Silent/low Noise) Windows 98 SE:

    QDI Legend V2200 AGP +Diamond Monster 3D +Videologic Apocalypse 3Dx | ASUS P2B-B | PII 450 | 128MB | 32GB CF
    Matrox G400 MAX +Matrox m3D +Orchid Righteous 3D² SLI | ASUS P3B-F | PIII 1100 | 256MB | 8GB CF
    Voodoo 5 5500 AGP | ASUS TUSL2-M | PIII-S 1400 | 256MB | 120GB SSD
    Voodoo 5 5500 AGP | EPoX EP-8K5A3+ | AthlonXP 3000+ | 512MB | 16GB CF |

    3 Mal editiert, zuletzt von Daywhite_81 ()

  • Fatal Racing läuft mit Voodoo2 und angepasster Batch Datei. :thumbsup:


    Hier (VOGONS Forum) kann die Batch Datei samt 3dfx patch heruntergeladen werden.


    Das ist der Inhalt der *.bat Datei, für den Fall das es jemand selbst machen will oder der Download irgendwann nicht mehr verfügbar ist.


    set SST_GRXCLK=90
    set SST_FT_CLK_DEL=0x4
    set SST_TF0_CLK_DEL=0x6
    set SST_TF1_CLK_DEL=0x6
    set SST_VIN_CLKDEL=0x1
    set SST_VOUT_CLKDEL=0x0
    set sst_SLIDETECT=0
    SET FX_GLIDE_SWAPINTERVAL=1
    set SST_TMUMEM_SIZE=2
    SET SST_FASTMEM=1
    SET SST_FASTPCIRD=1
    SET SST_SWAP_EN_WAIT_ON_VSYNC=1
    fatfx /fx480


    Diese Batch Datei funktioniert auch für Tomb Raider mit Voodoo 2 und den normalen 3dfx patch für Voodoo 1.
    Es muss nur das fatfx durch tomb ersetzt werden!

    3dfx SYSTEME (Silent/low Noise) Windows 98 SE:

    QDI Legend V2200 AGP +Diamond Monster 3D +Videologic Apocalypse 3Dx | ASUS P2B-B | PII 450 | 128MB | 32GB CF
    Matrox G400 MAX +Matrox m3D +Orchid Righteous 3D² SLI | ASUS P3B-F | PIII 1100 | 256MB | 8GB CF
    Voodoo 5 5500 AGP | ASUS TUSL2-M | PIII-S 1400 | 256MB | 120GB SSD
    Voodoo 5 5500 AGP | EPoX EP-8K5A3+ | AthlonXP 3000+ | 512MB | 16GB CF |

    2 Mal editiert, zuletzt von Daywhite_81 ()

  • Hallo,


    zum besseren Verständnis:
    Kann mir jemand erklären wozu diese Batch-Dateien gut sind und was die machen?


    Danke und beste Grüße

  • In unserem Fall führt die Batch Datei diverse Befehle aus bevor das Spiel (die *.exe Datei) gestartet wird.


    z.B.:
    set sst_SLIDETECT=0 bedeutet das der SLI Modus deaktiviert wird.
    set sst_TMUMEM_SIZE=2 bedeutet das der Texturspeicher auf 2MB begrenzt wird


    Hier findet man alle Befehle und deren Bedeutung.


    Man erstellt einfach eine Textdatei (*.txt) schreibt das gewollte wie oben geschrieben hinein und speichert.
    Danach ändert man *.txt in *.bat und fertig ist die Batch Datei, ein Doppelklick führt sie dann aus.
    Nachträgliches ändern der *.bat geht mit "Rechtsklick" und "bearbeiten".


    Man kann sämtliche Befehle auch jedes mal händisch in der Eingabeaufforderung eingeben, aber so gehts halt mit nur einem Klick jedes mal Automatisch.


    https://de.wikipedia.org/wiki/BAT-Datei

    3dfx SYSTEME (Silent/low Noise) Windows 98 SE:

    QDI Legend V2200 AGP +Diamond Monster 3D +Videologic Apocalypse 3Dx | ASUS P2B-B | PII 450 | 128MB | 32GB CF
    Matrox G400 MAX +Matrox m3D +Orchid Righteous 3D² SLI | ASUS P3B-F | PIII 1100 | 256MB | 8GB CF
    Voodoo 5 5500 AGP | ASUS TUSL2-M | PIII-S 1400 | 256MB | 120GB SSD
    Voodoo 5 5500 AGP | EPoX EP-8K5A3+ | AthlonXP 3000+ | 512MB | 16GB CF |

  • Ich habe das Spiel heute mit einer V2 starten probiert.
    Also ich denke das auf jeden Fall der V1 patch genommen werden muss.
    Damit startete das Spiel jedoch ohne Bild und nur Musik.


    Deiner Signatur nach vermute ich mal, daß Du das auf diesem Rechner getestet hast:
    ASUS P3B-F, PIII 1100, 512MB, Matrox G400 MAX +Matrox m3D +Orchid Righteous 3D² SLI, 8GB CF, Win98SE?


    Vermutlich mit dem Treiber 3.02.02?


    Dann vermute ich mal, daß Du auch ein Opfer des Problems geworden sein könntest, wonach sich bei Tomb Raider mit Voodoo-Patch ein Pentium 3, ein i440BX, ein Voodoo²-SLI und der Treiber 3.02.02 nicht miteinander vertragen:
    Asus P3B-F, PIII-1100 SL5QW, DOS-Programme


    Probier doch mal eine der folgenden Lösungen aus, dann müßte es auch ohne Batch-Datei gehen:
    - Tausche den Pentium III gegen einen Pentium II
    - Tausche das i440BX-Board gegen ein i815-Board (zugegebenermaßen sehr unpraktikabel)
    - Entferne eine der beiden Voodoo²-Karten oder
    - Verwende statt Version 3.02.02 die Treiberversion 3.03.00 Beta


    Mein SLI-Gespann steckt in den Slots 2 und 3, meine Netzwerkkarte in 4, meine Soundkarte in 6 und es läuft ohne Probleme und zusätzlichen Batch-Dateien.

    Ich werde mich von keinem einzzzigen Prozzzessor trennen.
    Jedoch lockt es mich beinahe, ihn Dir zu überlassen, nur um zu sehen, wie er Dich in den Wahnsinn treibt :evil:


    Meine Begehren

  • Dann vermute ich mal, daß Du auch ein Opfer des Problems geworden sein könntest, wonach sich bei Tomb Raider mit Voodoo-Patch ein Pentium 3, ein i440BX, ein Voodoo²-SLI und der Treiber 3.02.02 nicht miteinander vertragen:


    Soweit alles richtig, funktioniert hat es bisher nur mit einer V2 in PCI Slot 2, die Zweite aus Slot 3 entfernt.
    Im SLi funktionierte es nicht, nur Ton ohne Bild, gleich wie ohne Batch Datei, der Rush Patch verursachte mit V2 immer einen Absturz obwohl laut andere dieser funktionieren soll.


    LAN ist bei mir in PCI 5 und die m3D in PCI 4, Sound in der einzigen ISA.


    Werd ich mal ausprobieren, Slot 1 Boards hab ich folgende noch P2B, P2B-B, GA-6BA, GA-686BX
    Die Chipsätze davon weis ich auf die schnelle jetzt nicht.

    3dfx SYSTEME (Silent/low Noise) Windows 98 SE:

    QDI Legend V2200 AGP +Diamond Monster 3D +Videologic Apocalypse 3Dx | ASUS P2B-B | PII 450 | 128MB | 32GB CF
    Matrox G400 MAX +Matrox m3D +Orchid Righteous 3D² SLI | ASUS P3B-F | PIII 1100 | 256MB | 8GB CF
    Voodoo 5 5500 AGP | ASUS TUSL2-M | PIII-S 1400 | 256MB | 120GB SSD
    Voodoo 5 5500 AGP | EPoX EP-8K5A3+ | AthlonXP 3000+ | 512MB | 16GB CF |

  • Slot 1 Boards hab ich folgende noch P2B, P2B-B, GA-6BA, GA-686BX
    Die Chipsätze davon weis ich auf die schnelle jetzt nicht.

    Auf den ersten und auch auf den zweiten Blick sind die beiden Asus und die beiden Gigabyte Boards mit dem i440BX bestückt.


    Bin schon gespannt auf Deine Testresultate :spitze:


    Der Prozessortausch ist eigentlich auch problemlos möglich. Slot1 sei Dank. Kannst Du vielleicht auch noch probieren. Dann sollte es auch mit SLI gehen, ebenso wie mit dem Beta-Treiber. War jedenfalls bei meinem System so.

    Ich werde mich von keinem einzzzigen Prozzzessor trennen.
    Jedoch lockt es mich beinahe, ihn Dir zu überlassen, nur um zu sehen, wie er Dich in den Wahnsinn treibt :evil:


    Meine Begehren

    Einmal editiert, zuletzt von Lotosdrache ()

  • Bin schon gespannt auf Deine Testresultate :spitze:
    Der Prozessortausch ist eigentlich auch problemlos möglich. Slot1 sei Dank.


    Das mit dem Prozessortausch, probier ich auf jeden Fall, geht ja schnell ;)
    Vielleicht geht nur der Coppermine nicht und der Katmai schon, oder doch der Slotket Adapter, leider hab ich keinen Slot1 Coppermine, nur Katmai, viell. sollte ich mir da mal einen zulegen.
    Die anderen drei Boards (außer P2B-B, das ist fix verbaut) werde ich evtl. auch mal prüfen, hab ja von allen betriebsbereite Ghost images mit Win98SE, da geht das recht flott.


    Das einzige Problem welches ich mit PCI Slots bisher hatte war im P2B-B, da hab ich drei Grafikkarten drinnen und die wollten nicht so funktionieren wie ich das angedacht hatte.
    Das System bestimmte also in welchen Slot welche Karte steckt, damit das auch funktioniert. Eigentlich sollte die Netzwerkkarte zwischen die drei damit nicht drei Kühlerlose GPUs nebeneinander heizen, aber das funktionierte nicht. Der IRQ der PowerVR wurde nicht zugewiesen, auch nicht wenn man im BIOS nachhelfen wollte. Naja jetzt rennt das System einwandfrei, ärgerlich war es trotzdem.

    3dfx SYSTEME (Silent/low Noise) Windows 98 SE:

    QDI Legend V2200 AGP +Diamond Monster 3D +Videologic Apocalypse 3Dx | ASUS P2B-B | PII 450 | 128MB | 32GB CF
    Matrox G400 MAX +Matrox m3D +Orchid Righteous 3D² SLI | ASUS P3B-F | PIII 1100 | 256MB | 8GB CF
    Voodoo 5 5500 AGP | ASUS TUSL2-M | PIII-S 1400 | 256MB | 120GB SSD
    Voodoo 5 5500 AGP | EPoX EP-8K5A3+ | AthlonXP 3000+ | 512MB | 16GB CF |

    Einmal editiert, zuletzt von Daywhite_81 ()

  • Probier doch mal eine der folgenden Lösungen aus, dann müßte es auch ohne Batch-Datei gehen:
    - Tausche den Pentium III gegen einen Pentium II
    - Entferne eine der beiden Voodoo²-Karten oder


    - Tausche den Pentium III gegen einen Pentium II (geht mit PII und PIII Katmai, aber nur mit Batch-Datei, ansosten siehe Foto)
    - Entferne eine der beiden Voodoo²-Karten (nur so möglich, mit SLI kein Bild nur Ton!)


    Bild ohne Batch-Datei und Voodoo patch.
    [IMG:http://abload.de/thumb/tr_v2_p400_cimg0024d3jf8.jpg][IMG:http://abload.de/thumb/tr_v2_p400_cimg00250xjgr.jpg]

    3dfx SYSTEME (Silent/low Noise) Windows 98 SE:

    QDI Legend V2200 AGP +Diamond Monster 3D +Videologic Apocalypse 3Dx | ASUS P2B-B | PII 450 | 128MB | 32GB CF
    Matrox G400 MAX +Matrox m3D +Orchid Righteous 3D² SLI | ASUS P3B-F | PIII 1100 | 256MB | 8GB CF
    Voodoo 5 5500 AGP | ASUS TUSL2-M | PIII-S 1400 | 256MB | 120GB SSD
    Voodoo 5 5500 AGP | EPoX EP-8K5A3+ | AthlonXP 3000+ | 512MB | 16GB CF |

  • - Tausche den Pentium III gegen einen Pentium II (geht mit PII und PIII Katmai, aber nur mit Batch-Datei, ansosten siehe Foto)


    Ja, diesen "CGA"-Style hatte ich vor Jahren auch mal beim Testen wie es bei mir am besten funktioniert. Hast Du in der Konfiguration dann mal den VoodooRush-Patch installiert? Ich glaube, der behob das Farbenchaos manchmal. Manchmal aber auch nicht -> Absturz. Bin mir aber nicht mehr sicher.


    Interessant, daß der Katmai auf i440BX mit V²-SLI und Treiber 3.02.02 funktioniert :spitze: !
    Hab ich doch richtig verstanden, oder?
    Nur seltsam, daß Du dabei immer noch die Konfig-Batch-Datei brauchst. Da könnte evtl. Slot-Hüpfen helfen :S
    Ich hab bisher immer eine Konfiguration gefunden, in der ich sie nicht brauchte.
    Meine Coopermines (SL4BS, SL4ZJ, SL5QW) taten es auf dem P3B-F allesamt nicht mit dem SLI: Asus P3B-F, PIII-1100 SL5QW, DOS-Programme


    Bleibt also noch der Beta-Treiber und ein anderes Board für den PIII übrig...

    Ich werde mich von keinem einzzzigen Prozzzessor trennen.
    Jedoch lockt es mich beinahe, ihn Dir zu überlassen, nur um zu sehen, wie er Dich in den Wahnsinn treibt :evil:


    Meine Begehren

    2 Mal editiert, zuletzt von Lotosdrache ()

  • Ja, diesen "CGA"-Style hatte ich vor Jahren auch mal beim Testen wie es bei mir am besten funktioniert. Hast Du in der Konfiguration dann mal den VoodooRush-Patch installiert? Ich glaube, der behob das Farbenchaos manchmal. Manchmal aber auch nicht -> Absturz. Bin mir aber nicht mehr sicher.


    Da hast jetzt was falsch verstanden, mit SLI hat es nie funktioniert, hab Fatal Racing immer gleich mit probiert, da es die selbe Batch-Datei braucht um zu laufen, gleiche Ergebnisse wie bei TR.


    Hier noch mal genau in welchen Konfigurationen ich es ausgeführt habe, immer mit Voodoo Graphics Driver kit Version: 3.01.00:
    PII 400, V2, Batch-Datei, Voodoo patch -> einwandfrei
    PII 400, V2, Voodoo patch -> "CGA" style
    PII 400, V2, Rush patch -> kein Bild, nur Ton
    PII 400, V2 SLI, Batch-Datei, Voodoo patch -> kein Bild, nur Ton


    PIII 500, V2, Batch-Datei, Voodoo patch -> einwandfrei
    PIII 500, V2, Voodoo patch -> "CGA" style
    PIII 500, V2, Rush patch -> kein Bild, nur Ton
    PIII 500, V2 SLI, Batch-Datei, Voodoo patch -> kein Bild, nur Ton


    Die selben Ergebnisse lieferte auch Fatal Racing, mit V2 und Batch-Datei einwandfrei und mit V2SLI nur Ton ohne Bild.

    3dfx SYSTEME (Silent/low Noise) Windows 98 SE:

    QDI Legend V2200 AGP +Diamond Monster 3D +Videologic Apocalypse 3Dx | ASUS P2B-B | PII 450 | 128MB | 32GB CF
    Matrox G400 MAX +Matrox m3D +Orchid Righteous 3D² SLI | ASUS P3B-F | PIII 1100 | 256MB | 8GB CF
    Voodoo 5 5500 AGP | ASUS TUSL2-M | PIII-S 1400 | 256MB | 120GB SSD
    Voodoo 5 5500 AGP | EPoX EP-8K5A3+ | AthlonXP 3000+ | 512MB | 16GB CF |

    3 Mal editiert, zuletzt von Daywhite_81 ()

  • Batch Datei mit Rush-Patch hast Du nicht ausprobiert?


    Beste Grüße


    Soeben probiert, das Spiel wird im Software Modus gestartet.

    3dfx SYSTEME (Silent/low Noise) Windows 98 SE:

    QDI Legend V2200 AGP +Diamond Monster 3D +Videologic Apocalypse 3Dx | ASUS P2B-B | PII 450 | 128MB | 32GB CF
    Matrox G400 MAX +Matrox m3D +Orchid Righteous 3D² SLI | ASUS P3B-F | PIII 1100 | 256MB | 8GB CF
    Voodoo 5 5500 AGP | ASUS TUSL2-M | PIII-S 1400 | 256MB | 120GB SSD
    Voodoo 5 5500 AGP | EPoX EP-8K5A3+ | AthlonXP 3000+ | 512MB | 16GB CF |

  • Hier ein weiterer Beitrag zum Thema Problemlösung mit Tomb Raider und 3dfx Karten.


    Ich werde diese Anleitung auch noch probieren, da ich das SLI nicht mit TR zum laufen gebracht habe.

    3dfx SYSTEME (Silent/low Noise) Windows 98 SE:

    QDI Legend V2200 AGP +Diamond Monster 3D +Videologic Apocalypse 3Dx | ASUS P2B-B | PII 450 | 128MB | 32GB CF
    Matrox G400 MAX +Matrox m3D +Orchid Righteous 3D² SLI | ASUS P3B-F | PIII 1100 | 256MB | 8GB CF
    Voodoo 5 5500 AGP | ASUS TUSL2-M | PIII-S 1400 | 256MB | 120GB SSD
    Voodoo 5 5500 AGP | EPoX EP-8K5A3+ | AthlonXP 3000+ | 512MB | 16GB CF |