Der "An was bastelt ihr gerade" Thread

  • HellScream2 Das Problem kenn ich. Und zu allem Übel kommen dann noch schlecht programmierte BIOSe und Betriebssysteme hinzu :topmodel:

    Ich werde mich von keinem einzzzigen Prozzzessor trennen.
    Jedoch lockt es mich beinahe, ihn Dir zu überlassen, nur um zu sehen, wie er Dich in den Wahnsinn treibt :evil:

    Meine Begehren

  • :thumbup::bonk:8) jemand der mich versteht.

    Asus P5E VM-HDMI S.775 / Intel Xeon X5460 @ S.775 Mod. / 4x 2GB A-DATA Vitesta Extreme Edition DDR2-800+ / EVGA GTX 570 Classified

    Asus Maximus Formula Special Edition S.775 / Intel Core2 Extreme QX6850 / 4x 1GB Crucial Ballistix Tracer-1066/PC2-8500 / Evga Geforce GTX 285 FTW

    DFI LanParty NF4 SLI-DR Expert / AMD Athlon 64 FX 60 Dual-Core / 4x 1GB OCZ EL Platinum @ OCZ Kühler / SLI @ NVIDIA GeForce 8800GTS 512MB G92

  • :D bin im Keller, unser Haus ist VOLL-unterKellert und der Keller ist Voll-ausgeBaut ..... mit Vorraum, Flur, Treppe nach draußen, Bügelzimmer, Heizungsraum und jetziger Teile lagerungsRaum :bonk:, dann 2x ComputerZimmer und HeimKino im Aufbau (habs aus einem der Computerzimmer demontiert:mauer: ).

    Ich räum jetzt erstmal ALLES ordendlich auf, MIT Beschriftung :spitze: und dann schau Ich das mein Main PC endlich fertig wird, bin da ja erst xx Monate bei :steinigung:.

    Muß meine Frau ja mal loben.... DANKE Schatz, das ich mir SOOOOOOO viel "Zeugs" kaufen/sammeln darf :love:


    Ach und einen MultiBoot USB Stick mit je 32/64bit Windows: XP, Vista, 7, 10, dazu diverse RettungsProgramme (zb. Hiren's BootCD PE) und diverse Software.

    Ich möchte dazu auch noch einige Linux BS installieren und passende Software.

    Ein ALLES in einem USB-Stick, läuft bisher hervorragend.

    Asus P5E VM-HDMI S.775 / Intel Xeon X5460 @ S.775 Mod. / 4x 2GB A-DATA Vitesta Extreme Edition DDR2-800+ / EVGA GTX 570 Classified

    Asus Maximus Formula Special Edition S.775 / Intel Core2 Extreme QX6850 / 4x 1GB Crucial Ballistix Tracer-1066/PC2-8500 / Evga Geforce GTX 285 FTW

    DFI LanParty NF4 SLI-DR Expert / AMD Athlon 64 FX 60 Dual-Core / 4x 1GB OCZ EL Platinum @ OCZ Kühler / SLI @ NVIDIA GeForce 8800GTS 512MB G92

    Edited 3 times, last by HellScream2 (March 30, 2020 at 9:25 AM).

  • Nix am PC, aber trotzdem viel Spaß dabei: einmal Heizungswärmetauscher neu nach fast 31 Jahren.

    Images

    Voodoo: Athlon XP-2800+ auf MSI KT3-Ultra 2, 1GB DDR, Voodoo 5 5500 AGP, SB Audigy Platinum EX, Win98SE
    Voodoo²: Athlon XP-2400+ auf MSI K7T266Pro2, 1GB DDR, Nvidia GF3TI500 und Voodoo 2 SLI, SB Audigy 2ZS, Win98SE

    Mainsys: Ryzen 5-3600 auf Asus Prime B350-Plus, 32GB DDR4 3200, RTX2070, Win 11

    Midrange: 2x Xeon 3,2GHz Dell Precision 450, 3GB DDR, ATI HD3850 AGP, SB X-Fi mit Frontpanel, WinXP

  • Das ist die letzte Drecksarbeit, ein so kleines und billiges Teil so tief zu verbauen :bonk::mauer:.... ein Freund von mir hat das jetzt schon ca. 5x gemacht: Audi V8 3x und Audi A6 1x, den anderen hab ich vergessen.

    Asus P5E VM-HDMI S.775 / Intel Xeon X5460 @ S.775 Mod. / 4x 2GB A-DATA Vitesta Extreme Edition DDR2-800+ / EVGA GTX 570 Classified

    Asus Maximus Formula Special Edition S.775 / Intel Core2 Extreme QX6850 / 4x 1GB Crucial Ballistix Tracer-1066/PC2-8500 / Evga Geforce GTX 285 FTW

    DFI LanParty NF4 SLI-DR Expert / AMD Athlon 64 FX 60 Dual-Core / 4x 1GB OCZ EL Platinum @ OCZ Kühler / SLI @ NVIDIA GeForce 8800GTS 512MB G92

  • Ja, hat aber den Vorteil dass man auf dem Weg dahin noch viel mehr findet und mit erledigen kann (sollte) :P

    Voodoo: Athlon XP-2800+ auf MSI KT3-Ultra 2, 1GB DDR, Voodoo 5 5500 AGP, SB Audigy Platinum EX, Win98SE
    Voodoo²: Athlon XP-2400+ auf MSI K7T266Pro2, 1GB DDR, Nvidia GF3TI500 und Voodoo 2 SLI, SB Audigy 2ZS, Win98SE

    Mainsys: Ryzen 5-3600 auf Asus Prime B350-Plus, 32GB DDR4 3200, RTX2070, Win 11

    Midrange: 2x Xeon 3,2GHz Dell Precision 450, 3GB DDR, ATI HD3850 AGP, SB X-Fi mit Frontpanel, WinXP

  • Gestern endlich mal den Hardware-Trödel eingebaut welcher schon wochenlang hier rumgammelt....

    - Kühler Fuma 2 eingebaut

    - M.2 SSD eingebaut, fürs System

    - 2x 4TB HD eingebaut, fürs Gedaddel

    - alles gleich mal sauber gemacht

  • Grad ein bisschen am Voodoo 1 System weiter gemacht, Kühler auf den Pentium 2 300 gesetzt und den eingebaut (getestet hatte ich mit nem 400ter, der ist mir aber zu schnell für das System), jetzt mal gucken ob er noch bootet ;)

    Voodoo: Athlon XP-2800+ auf MSI KT3-Ultra 2, 1GB DDR, Voodoo 5 5500 AGP, SB Audigy Platinum EX, Win98SE
    Voodoo²: Athlon XP-2400+ auf MSI K7T266Pro2, 1GB DDR, Nvidia GF3TI500 und Voodoo 2 SLI, SB Audigy 2ZS, Win98SE

    Mainsys: Ryzen 5-3600 auf Asus Prime B350-Plus, 32GB DDR4 3200, RTX2070, Win 11

    Midrange: 2x Xeon 3,2GHz Dell Precision 450, 3GB DDR, ATI HD3850 AGP, SB X-Fi mit Frontpanel, WinXP

  • Der soll echt gut sein, aber den aus einem Test auf Computerbase. Ich da auf alle Fälle gespannt.

    Permanent aufgebaut:
    A7V133, Athlon 1,4GHz, 512MB, GeForce3 Ti200 128MB, SB Live! X-Gamer
    Für die LAN:
    TUSL2-C, PIII-S 1,4GHz, 512MB, GeForce2 GTS 32MB, 2x Monster II 12M, SB Live!
    TUSL2-C, PIII-S 1,4GHz, 512MB, GeForce2 GTS 32MB, 2x Monster II 12M, SB Live!
    CUSL2-C, PIII 933MHz, 512MB, G400 Max 32MB AGP, 2x 3D Blaster Voodoo² 12MB, SB Live!
    CUSL2-C, PIII 933MHz, 512MB, G400 Max 32MB AGP, 2x Monster II 8MB, SB Live!

  • Habe heute endlich Zeit und Mut gefunden meinen alten, treuen DELL XPS L702X auseinander zu nehmen, zu reinigen und neue WLP aufzutragen.

    Im Sommer 2011 gekauft war er als mobile 3D Workstation gedacht und hat bis zum Umstieg auf den AMD 1950X Ende 2017 treue Dienste geleistet.

    • Sandy Bridge i7 2630QM 2GHz Base / 2,6GHz All Core Turbo / 2,9GHz Single Core Turbo
    • 16GB DDR3 1333 MHz
    • 500GB Intel SSD + 1TB WD HDD
    • nVidia GeForce GT555 M - 3072 MB DDR3, Core: 590 MHz, RAM: 900 MHz
    • 17,3" LED Display
    • Windows 7 Pro

    Maya, Modo, ZBrush, VRay, Arnold, Photoshop, Mari, Substance ... Nächte durchrendern ... was hab ich dem nicht alles angetan :topmodel:

    Zum Schluss hat er schon gar nicht mehr den Boost Takt angelegt und der Lüfter lief kurz nach dem Einschalten schon auf sehr hoher Drehzahl.
    Beim Rendern hing er auf der Base Clock fest weil die CPU schon bei 90°C war. Den linken Handballen konnte ich schon nicht mehr für längere Zeit auflegen weil die Fläche darunter so heiß wurde.


    Es war nicht wenig Aufwand, um an die Kühlkonstruktion zu kommen. Schraubentypen und Anzahl waren aber überall gut markiert und der Zusammenbau war wieder recht einfach. Hab noch nie nen Laptop so weit auseinander genommen 8o Mal eine HDD gewechselt. Das wars.

    Jetzt läuft er aber wieder wie am ersten Tag. Boost Takt liegt auch wieder an und wird gehalten bei maximal 72°C.
    In Cinebench R15 macht er 442 im Multicore und 101 im Single Core. Ist heute natürlich kein highlight mehr.
    Vielleicht lasse ich mal GATs x264 durchlaufen ;)

    Voodoo-Kiste (seit 3dfx BayernLAN 2007):
    TUSL2-C, P3-S 1400, 512MB SDR, Voodoo 5 5500 AGP, 9,1GB IBM SCSI (OS), 40GB HDD (Games), Adaptec 2940-U2W SCSI
    Dualatin: GA-6VTXD, 2x P3-S 1400, 1GB SDR, 2x 60GB, Hercules Radeon 8500 128MB

    Work (CG): MSI TRX40 Creator, AMD TR 3970X, 128GB RAM, Titan RTX 24GB, Win10Pro

    Zock & Office: MSI X58 Pro-E, Xeon X5680 4,2GHz, 24GB RAM, RX590 8GB, KDE Neon

  • Ich habe hier einen sehr übel zugerichteten Teac Verstärker stehen. Ich weiß nicht, was der Vorbesitzer damit angestellt hat, bevor ich das Ding beim Sperrmüll aufgesammelt hab, aber es ist brutal: Es fehlen Teile, interne Kabel sind durchgeschnitten, es sind Löcher mit ~3mm Durchmesser in die Platine gebohrt (?!) und Leiterbahnen sind abgerissen. Ich finde aber das Gerät vom Aussehen her so cool, dass ich mich der Herausforderung stellen werde, und versuche, das Ding zu reparieren. Ich muss jetzt erstmal genau schauen, was alles fehlt und ein paar Teile ordern ....


    Das Bild ist aus dem Netz geliehen, Link hier

  • sehr schöner Design aber wieso hat der letzte Besitzer sich so viel Mühe gegeben das Gerät derart zu zerstören ????

    Asus P5E VM-HDMI S.775 / Intel Xeon X5460 @ S.775 Mod. / 4x 2GB A-DATA Vitesta Extreme Edition DDR2-800+ / EVGA GTX 570 Classified

    Asus Maximus Formula Special Edition S.775 / Intel Core2 Extreme QX6850 / 4x 1GB Crucial Ballistix Tracer-1066/PC2-8500 / Evga Geforce GTX 285 FTW

    DFI LanParty NF4 SLI-DR Expert / AMD Athlon 64 FX 60 Dual-Core / 4x 1GB OCZ EL Platinum @ OCZ Kühler / SLI @ NVIDIA GeForce 8800GTS 512MB G92

  • Das kann ich dir nicht sagen, ich hab aber mal Fotos vom PCB gemacht, das sieht echt übel aus ... 65 Bauteile habe ich als optisch fehlend oder defekt eingegrenzt, mal sehen, was ich davon da habe, und was ich bestellen muss .... Außerdem sind Löcher in den Kühlkörper gebohrt, an Stellen, wo sie garantiert nicht original sind?! Vielleicht wollte der Originalbesitzer das Gerät anch defekt umbauen und eine eigene Endstufe einbauen und hat aufgegeben ... Keine Ahnung, aber ein nettes Projekt für die Quarantäne.

  • Oh man 8|, das sieht wirklich ziemlich übel aus! Viel Erfolg bei der Reparatur!

    Übrigens mag ich solch alte Amplifier/Receiver auch und meine Liebe zu analogen VU-Meter habe ich ja schon vorher hier bekannt gegeben. :love:

    Die Pixel beschleunigt, die Kanten gefixt, lang leben die Karten von 3dfx! :spitze:

  • Gestern meinen zweiten Pioneer Amplifier repariert. Der war eigentlich als Ersatzteilträger für mein Hauptgerät gedacht. Auch nicht schlecht, habe ich jetzt 2 funktionierende Geräte. :spitze:

    Heute dann nur noch alles zusammen schrauben (Gehäuse und Frontblende) und eventuell noch die Potis reinigen.

    Die Pixel beschleunigt, die Kanten gefixt, lang leben die Karten von 3dfx! :spitze:

  • Am Haus 8o

    Hab mal noch den Estrich inspiziert und zwei Tote Wespenkolonien gefunden. Zudem diverse dieser "Anfangsnester" welche die Königinen bauen, alles verlassen bzw. tot und nun auch entfernt.

    Ansonsten neigt sich der Umzug und das Einrichten dem Ende zu.

  • Hatte vorgestern wegen Kopfschmerzen und Schwindelgefühlen :( keine Lust, stundenlang auf den BIOS-Code des GA-5AX zu starren, um die letzte noch fehlende Funktion Force Snoop INV zu aktivieren. Na ja, vielleicht auch vorletzte Funktion, man findet ja nie ein Ende, sondern immer nur noch mehr Haare in der Suppe, also dem BIOS. :rolleyes: Ich überlege noch, ob ich versuchen soll, die Cachefunktion für den Schatten-RAM von C0000-FFFFF zu aktivieren. Aber nur, wenn's nicht zu viel Arbeit macht :S Jedenfalls dachte ich mir, ich versuche mal, mein neu erworbenes Wissen im Reverse Engineering in der Praxis einzusetzen, um ein anderes Problem zu lösen.

    Zunächst die Hardware:

     

    - Enermax Silver Wizard II

    - PowerColor P561A (ALi Aladdin 7 Chipsatz)

    - AMD K6-III+/ATZ400@550MHz

    - 2x 256 MiB Micron PC133U-222-542-Z

    - ArtX onboard Grafik

    - 2x Diamond Monster 3DII 12 MiB (Rev. A) im SLI

    - NIC 3Com 3C905B-TX Fast Etherlink XL PCI

    - Diamond Monster Sound MX300 (Aureal Vortex2) mit Digital I/O-Board

    - Diamond Monster Midi 4 MiB (Roland GS Wavetable)

    - 2x 80 GiB Maxtor HDD

    - Samsung DVD

    - Aopen CD-RW

    - 3,5" Disketten-LW

    Betriebssysteme: Windows 98SE und DR-DOS 7.03.

    Und bei letzterem gibt's Probleme. Eines davon im REAL-Mode also mit HIMEM.SYS als Speichermanager statt EMM386.EXE:

    UMBPCI.SYS unterstützt den Chipsatz nicht ;( kann also die Chipsatzregister, die die Speicherbereiche für den Schatten-RAM aktivieren, nicht konfigurieren. Die Nummern der Offsets und die Funktionen der einzelnen Bits darin sind schlicht nicht bekannt. Und weil man auch nirgends ein Datenblatt für den Chipsatz auftreiben kann, ist es nicht so leicht, das heraus zu finden. Gibt ja nur 256 mögliche Offsets mit je 8 Bits für die Konfiguration. :bonk:Folglich hatte ich im Real-Mode keine UMBs zur Verfügung, um DOS-Treiber aus dem konventionellen RAM hochzuladen. Mir blieben nur 562.912 Byte freier Hauptspeicher - ohne Netzwerktreiber. Mit waren es nur noch 402.384 Byte. Da läuft keine Spiel mehr. Ein Ding der Unmöglichkeit... =O

    Aber ich hatte neulich Nacht eine Eingebung: Beim Revers Engineering des BIOS meines GA-5AX mit Aladdin V ist mir aufgefallen, daß das System-BIOS während des Bootvorgangs die Shadowfunktionen Read/Write für das E-Segment aktiviert und kurz darauf die Schreibfunktion wieder deaktiviert. Da die grundlegenden Schritte während des Bootvorgangs sich vermutlich nicht groß zwischen den Kisten unterscheiden, müßte ich also durch Reverse Engineering des Aladdin 7-BIOSes zumindest die Offsets für die Shadowfunktionen des E-Segments finden können.

    Nach ein bißchen surfen im KotCode hatte ich doch tatsächlich an der entsprechenden Stelle ähnliche Befehle gefunden, aus denen ich das Offset und verschiedene Funktionsvarianten ableiten konnte. Und mit ein bißchen Intuition beim Betrachten der Registerwerte, die mir WPCRedit unter Win98SE anzeigte, konnte ich auch die Lage der Offsets für das C-, D-, und F-Segment erahnen. :)

    Soweit ich die Funktionsweise von UMBPCI.SYS richtig verstanden habe, aktiviert es den Schreib-/Lesezugriff für die Schatten-RAM-Bereiche, indem es die entsprechende Konfiguration in den Chipsatzregistern ändert und unter MS-DOS die Funktion "Request XMS-UMB" bereitstellt. Zum Glück verwende ich DR-DOS und benötige daher letztere Funktion nicht. Lt. Dokumentation zu UMBPCI müßte es also reichen die RAM-Bereiche zu aktivieren, den Rest macht dann der Speichermanager von DR-DOS höchstselbst.

    Ich mußte also nur noch meinen BIOS-Code zur Umprogrammierung des Aladdin V mit den neuen Registeroffsets/-werten füttern, ein paar Compileranweisungen ändern und mit NASM eine COM-Datei daraus machen. In der autoexec.bat beim Booten von Win98SE gestartet funktionierte das Programm schon mal. Die Offsets wurden entsprechend geändert. Aber wie sieht das unter DR-DOS aus?

    Nun, der Treiber muß als erster in der config.sys noch vor dem Speichermanager geladen werden, da letzterer ja sonst den Schatten-RAM nicht in UMBs umwandeln kann. Und wie man aus einer COM-Datei einen SYS-Treiber macht, entzieht sich meiner Kenntnis. :( Aber DR-DOS kann mehr aus der config.sys heraus starten als MS-DOS. :)

    Also machte ich mich heute morgen frohgemut ans Werk. Erst ein Test vom DOS-Prompt aus: Programm lief, keine Fehlermeldung oder Abstürze. Soweit so gut :) Die config.sys editiert und...

    War dann doch etwas enttäuscht. Konnte die Datei nicht aus der config.sys heraus starten. Es kam irgendwas mit SECURITY.BIN 1.13 und das System hing fest. Auch die Versuche, nur einzelne Bereiche ohne die Cachefunktion zu aktivieren, scheiterten. ;( Vom DOS-Prompt aus ging es, aber das hilft ja nicht, wenn der Speichermanager nicht mehr mitbekommt, daß die Shadowregionen freigeschaltet wurden.

    ;(;(;(;(;(;(;(

    Wenigstens breitete der Lammbraten beim Mittagessen eine wohlige Wärme in mir aus und ich war tiefenentspannt, fast schon :sleeping:. Da fiel mir ein, ich hatte den falschen Befehl benutzt. EXE- und COM-Dateien in der CONFIG.SYS werden nicht mit DEVICE= sondern mit INSTALL=C:\COMMAND.COM /c geladen :mauer::mauer::mauer:

    Also zurück ans Reißbrett, CONFIG.SYS editiert und

    ES GEHT :hre::hre::hre::hre::hre:

    Also sofort für jede der 16 Regionen einen eigenen Treiber geschrieben und alle einzeln getestet. Ergebnis:

    Mein Reverse Engineering zum Auffinden der Registeroffsets für das E-Segment und zur Funktionsableitung der einzelnen Bits scheint richtig zu sein. Meine Intuition zur Ableitung der Registeroffsets für das C- und D-Segment aus den WPCRedit Registerwerten und deren Lage relativ zu den Offsets des E-Segments ebenfalls. :D Nur die Offsets für das F-Segment konnte ich nicht verifizieren. DR-DOS weigert sich bei mir beharrlich irgendwas nach F000-F7FF hochzuladen, obwohl das, nach allem was man so liest, gehen soll. Aber das war auch schon beim Aladdin V so X(

    Nun ja. Jetzt ist der DOS-REAL-Mode mit himem.sys jedenfalls schon viel praxistauglicher. Freier Konventioneller Speicher:

    ohne NIC, ohne UMB: 562.912 ( 550K ) REAL.TXT

    ohne NIC, mit UMB: 636.192 ( 621K ) REAL+UMB.TXT

    mit NIC, ohne UMB: 402.384 ( 393K ) REAL+NIC.TXT

    mit NIC, mit UMB: 560.336 ( 547K ) REAL+UMB+NIC.TXT

    Die 3Com-Netzwerktreiber bringen einen halt jedesmal ganz schön in die Bredouille. :rolleyes:

    Dank sei DR-DOS!!! Daß es nicht so dämlich ist wie MS-DOS :P und ohne UMBPCI.SYS auskommt. :spitze:

    Ich werde mich von keinem einzzzigen Prozzzessor trennen.
    Jedoch lockt es mich beinahe, ihn Dir zu überlassen, nur um zu sehen, wie er Dich in den Wahnsinn treibt :evil:

    Meine Begehren

  • die 3com Treiber sind echt Hardcore hungrig. Ich habe festgestellt dass Realtek Treiber recht schlank sind, vielleicht kannst du da noch was rausholen

    Aber mal ab vom Thema: was für ein rattengeiles layout das board hat=O:hre:

    Absolut geil :spitze: