Hardwarediagnosetools Win98

  • Hiho


    habe es nun endlich geschafft auf meinem kürzlich zusammengesteckten Retro-System (Athlon XP 2600+. ECS K7VTA3 v5.0/KT333, 2*512MB Corsair bling bling, V5 5500 mit Riserkabel) Windows 98 zu installieren (danke an Tweakstone für den hervorragenden Guide, hat der Erinnerung doch sehr gut auf die Sprünge geholfen ;)).


    Leider zeigt mein System einen recht lustigen Fehler: Es kann nicht neustarten. Will heißen, bei jedem reboot hängt sich das System beim Windows98-Screen auf, schalte ich den PC jedoch erst richtig aus und dann wieder an, bootet er durch, und bisher scheint er auch stabil zu sein (3DMark2001SE lief mehrfach durch, Q3A macht bisher auch keine Probleme).


    Nun wollte ich der Sache mal auf den Grund gehen, musste aber feststellen, dass die üblichen Verdächtigen in Sachen Diagnosetools sich nicht mehr ohne Weiteres einsetzen lassen.
    Prime95 will nicht starten, memtest86 habe ich keine Version gefunden, die ich ohne weiteres von der Kommandozeile starten kann (floppy/CDROM/USB-boot fällt alles aus), HD Tune 2.55 will nicht starten (kryptischer Fehler bzgl. POWRPROF.DLL). Aktuell bin ich froh überhaupt eine kompatible Version für cpuZ und WinRAR gefunden zu haben. :D


    Was nutzt ihr so für Stabilitätstests, insbesondere RAM/CPU?

    Voodoo²
    Elsa Victory II (Voodoo Banshee)
    Voodoo 3 3500
    Voodoo 4 4500 PCI
    Voodoo 5 5500 AGP
    :gadget:


    Aus dem Chaos sprach eine Stimme zu mir und sagte: "Lächle und sei froh, es könnte schlimmer kommen", und ich lächelte und ward froh und es kam schlimmer.

  • Aida64 läuft 100% mit W98 kann dir auch entsprechende Vollv. zusenden, ansonsten probier mal ob Orthos Prime geht...

  • Orthos werde ich mal probieren, obwohl laut Internetz auch die normale 32bit-prime95 Version unter Win98 funktionieren sollte, genau wie bei HD Tune 2.55 - bei mir leider nicht der Fall. ;(


    Funktioniert bei euch HD Tune (v2.55) unter Win98?

    Voodoo²
    Elsa Victory II (Voodoo Banshee)
    Voodoo 3 3500
    Voodoo 4 4500 PCI
    Voodoo 5 5500 AGP
    :gadget:


    Aus dem Chaos sprach eine Stimme zu mir und sagte: "Lächle und sei froh, es könnte schlimmer kommen", und ich lächelte und ward froh und es kam schlimmer.

  • Hatte mal Prime getestet ging bei mir auch nicht liegt eventuell an den Inoffiziellen W9 Servicepacks, aber bei Aida ist ein entsprechender Stabilitätstest dabei!


    Für die Festplatte ist bei Aida der Diskmark, vom prinzip nutze ich nur noch Aida weil das schlicht alles kann und ausliest...


    Was bei mir unter W98se auch nicht geht ist SuperPi, weiß da wer was?

    Edited once, last by Deletet ().

  • Moin,


    erstmal danke für die Blumen :D :spitze:
    Prime95 läuft soweit ich weiss bis v2414 unter Win98, diese Version habe ich mir zumindest abgelegt. v266 zB tuts nicht mehr.
    HDTune 2.55 läuft definitiv nicht unter Win98. Was möchtest du machen? Speedtest oder Errorscan?
    Für Speedtest eine alte HDTach Version verwenden (2.70 zB), zur Fehlersuche empfehle ich WD WinDLG für Full Read/Write und Speedfan für die Auswertung von SMART Werten.


    Memtests würde ich generell immer von einer Bootdisk machen, Tests unter Windows sind sehr unpräzise / du musst sie EWIG laufen lassen um einigermaßen behaupten zu können, dass dein RAM ordentlich arbeitet.


    Alternative sind 2 Prime Instanzen, eine mit Small FFTs, eine mit Blend.. Blend belegt auch gut RAM und reagiert gut auf defekten RAM.
    Ersetzt aber keinen Memtest ;)

  • Leider zeigt mein System einen recht lustigen Fehler: Es kann nicht neustarten. Will heißen, bei jedem reboot hängt sich das System beim Windows98-Screen auf, schalte ich den PC jedoch erst richtig aus und dann wieder an, bootet er durch, und bisher scheint er auch stabil zu sein (3DMark2001SE lief mehrfach durch, Q3A macht bisher auch keine Probleme).

    Speicher mal auf 512MB oder gar 256MB reduziert?
    Speichergröße in der system.ini angepasst?


    Falls ja:
    Nimm mal einen RAM-Riegel raus und versuchs nochmal, falls das dann geht s.o. bzw. setze die je in den anderen Slot,
    funktioniert es nun besser?
    Manchmal werden Riegel nur beim Start, aber nicht bei einem Reboot korrekt initialisiert, könnte daran liegen.
    Die Kontakte der RAMs zu reinigen hilft auch manchmal ;) - und bei diesem Fehlerbild würde ich auch die AGP+PCI
    Kontakte alle mal säubern..


    Wie schauen die Boardspannungen unter Idle + Last aus? OC oder @Stock? Zum Überprüfen alles auf Standarttakt!
    Wenn das obige alles im Lot ist kommt noch ein Defekt irgendeiner Komponente/Karte in Betracht..


    Mal ne alte Knoppix zwischen 3.0 und 4.x ziehen, brennen, booten.. - da gibts bei vielen auch Memtest direkt von CD ;)
    Das hilft oft viel weiter. Alternative: Windows XP PE CD und ein USB-Stick mit allen benötigten tools.

  • Leider zeigt mein System einen recht lustigen Fehler: Es kann nicht neustarten. Will heißen, bei jedem reboot hängt sich das System beim Windows98-Screen auf, schalte ich den PC jedoch erst richtig aus und dann wieder an, bootet er durch, und bisher scheint er auch stabil zu sein (3DMark2001SE lief mehrfach durch, Q3A macht bisher auch keine Probleme).

    Welches Netzteil hast du verbaut? Klingt nach LC Power :topmodel:
    Hatte das gleiche Problem mal mit so einem Netzteil. Alternativ kann eventuell auch ein Netzteil eines anderen Hersteller solche Symptome (wenn es defekt ist) hervorrufen.


    Hardwarediagnose

    Alternativ:

    • Everest Ultimate 5.5, vereint viele Funktionen, das Einzige was fehlt ist ein Errorscan. Sonst ist alles an Board.

    Die Pixel beschleunigt, die Kanten gefixt, lang leben die Karten von 3dfx! :spitze:

  • Danke für die Antworten. :)


    Also den system.ini-Tweak hatte ich ganz vergessen, hat aber am Reboot-Problem nichts geändert, wie auch wildes Rumgetausche des RAMs und zugehöriger Steckplätze - bin also versucht zu glauben, dass das Board irgendwo ne Macke hat, aber solange es nur das ist, soll es mich nicht sonderlich stören - gerade prime ich mal durch, momentan sieht's gut aus. Mit Memtest muss ich mal sehen, das Board kann nicht von USB booten, ein Floppy-LW besitze ich nicht mehr und um eine CD zu brennen fehlt mir der Wille (und der Rohling) :D.
    Aktuell läuft auch alles auf Default-Takt, wobei ich schon wenig and en Timings rumgespielt habe und darauf reagieren Speicher und Board sehr empfindsam. Ich meine, dass ist ehemaliger Highend-DDR3200-RAM, da sollte bei 166MHz schon CL2-2-2-6 1T drin sein, die Spannung bekomme ich aber nur auf gute 2.8V und damit ist zumindest 1T nicht drin (back2desktop im 3Dmark01), daher fahre ich aktuell SPD-Werte.


    Ja, HD-Tach habe ich bereits ausprobiert, aber da kann man scheinbar nur mit Pro-Version write-Tests machen - meine Read-Werte sind zudem recht niedrig, irgendwas knapp über 30 MB/s, habe das Gefühl, dass evt der IDE2SATA-Adapter bremst (vielleicht aber die aus einer PS3 stammende 2,5"-SATA-HDD).


    Was auch nicht funktionierte (und das ist potentiell recht ärgerlich, da mein Gehäuse keinen 5,25"-Schacht hat): Externes USB-DVD-Laufwerk.
    Habe da einen recht schnieken DVD-Brenner, der von W98 auch anstandslos als Laufwerk erkannt wird, aber schmiert der PC quasi ab, wenn man eine CD (oder DVD) einlegt - die Maus kann man noch bewegen, aber man kann quasi nichts mehr machen, irgendwann kommt ein Bluescreen mit "der PC ist ausgelastet"; danach hilft nur noch ein Neustart. Der per IDE angeschlossene DVD-Brenner verrichtet seinen Job hingegen problemlos.
    Liegt's am Laufwerk (es funktioniert an meinem Win10-PC anstandslos) oder doch an was anderem?


    Avenger, mit LC-Power voll ins Schwarze getroffen. :D
    Ist aber ein neues 300W-Modell im SFX-Formfaktor. Ich kenne den nicht allzu guten Ruf dieser Marke, hatte allerdings auch früher eigentlich nie Probleme mit den Dingern.

    Voodoo²
    Elsa Victory II (Voodoo Banshee)
    Voodoo 3 3500
    Voodoo 4 4500 PCI
    Voodoo 5 5500 AGP
    :gadget:


    Aus dem Chaos sprach eine Stimme zu mir und sagte: "Lächle und sei froh, es könnte schlimmer kommen", und ich lächelte und ward froh und es kam schlimmer.

  • Auch wenn das LC Power neu ist würde ich es mal mit einem anderem Netzteil gegentesten. Mein Netzteil war auch "nur" ein paar Monate alt als es zu diesem Symptom kam.

    Die Pixel beschleunigt, die Kanten gefixt, lang leben die Karten von 3dfx! :spitze:

  • Ich tippe auch spontan auf das Netzteil als Ursache, denn deine Probleme kenne ich zu gut von anderen PC (wo es immer das Netzteil war).


    Orthos werde ich mal probieren, obwohl laut Internetz auch die normale 32bit-prime95 Version unter Win98 funktionieren sollte, genau wie bei HD Tune 2.55 - bei mir leider nicht der Fall. ;(


    Funktioniert bei euch HD Tune (v2.55) unter Win98?


    Memtest86 läuft auch auf jedem Win98-System. Allerdings nicht in der Eingabeaufforderung von Windows aus, sondern vom echten DOS Prompt (Windows nicht starten). Jede Win98 Installation setzt auf ein vorhandenes DOS auf (beim Starten F8 Taste drücken).


    Prime95 (die "95" im Namen steht für das Jahr) läuft definitiv schon unter Win9x, du hast vermutlich nur eine zu neue Version probiert.


    HDTune 2.55 kann unter Win98 nicht laufen, da Windows98 ein anderes Treibermodell zum Ansprechen der Festplatten benutzt. Die eizigen unterstützen Versionen sind: Win2000, WinXP, Vista und Win7 (Quelle). HD Tach 2.61 z.B. ist dazu jedoch in der Lage (Win9x).

    "Ich habe einen Penis! Und ich werde ihn benutzen..." ~Gronkh

    Edited 4 times, last by Xenozid ().

  • Also ich habe mal ein anderes Netzteil ausprobiert (gut, auch irgendein noname 350W-Ding), das hat jedenfalls nicht geholfen. Ich weiß ja, dass es seit jeher Tradition ist, das Netzteil zumindest als mögliche Fehlerursache mit ins Spiel zu bringen, hier aber scheint es tatsächlich an etwas anderem zu liegen. :D


    Weiterhin etwas rätselhaft verhält sich mein externes USB-Laufwerk. Wenn ich es ohne USB-Verlängerung (das eigentliche USB-Kabel ist verdammt kurz) direkt hinten an die USBs anschließe, kann es meistens entsprechende CDs/DVDs lesen, mit USB-Verlängerung geht nix, an den Front-USBs auch nicht. Kann es sein, dass das Ding nicht genug Saft bekommt?


    Eine weitere Überraschung erlebte ich, als ich mal das Front-Audiopanel anschließen wollte - Pin 9 und 10 sowie 5 und 6 waren per Jumper gebrückt, also abgezogen die Dinger und das Frontpanel angeschlossen, tja, kein Sound, weder hinten noch vorne, mit Jumpern geht's dann wieder (natürlich nur hinten raus)...



    Memtest werde ich beizeiten mal von DOS aus probieren zu starten.

    Voodoo²
    Elsa Victory II (Voodoo Banshee)
    Voodoo 3 3500
    Voodoo 4 4500 PCI
    Voodoo 5 5500 AGP
    :gadget:


    Aus dem Chaos sprach eine Stimme zu mir und sagte: "Lächle und sei froh, es könnte schlimmer kommen", und ich lächelte und ward froh und es kam schlimmer.

  • Also ich hab was memtest angeht für solche Zwecke ein USB Diskettenlaufwerk und davon sollte man auch booten können in der Athlon XP-Liga sollte die Boards das können.


    Da geht dann auch die aktuellste Version dann problemlos zu nutzen
    http://www.memtest.org/#downiso


    Ich sehe bislang abgesehen vom USB Stick Disketten und Diskettenlaufwerke auch noch nicht wirklich sterben, günstig kommt man da heutzutage ausserdem auch dran.


    CPU-Z sollte es beispielsweise geben als 32-Bit und dann auch lauffähig da war auch ein stabilitätstest mit drin, ob der was taugt weiss ich allerdings nicht.
    Allerdings sollte man sich auch immer bewusst sein, die alten Athlon XP's laufen eh immer Volldampf und Windows98SE/ME/NT kennen noch kein Speedstep/Cool 'n' Quiet
    Also eine instabil laufende CPU sollte da dann doch recht schnell auffallen ;-)


    Gruss Dennis

  • //Edit:

    Was nutzt ihr so für Stabilitätstests, insbesondere RAM/CPU?


    RAM Fehlertest:
    Memtest86+ (nur unter DOS)


    Hardwaremonitoring:
    Motherboard Monitor 5 (MBM5, deutsche Sprachdatei) (Win9x, ME, NT, 2000, XP und NET)
    CPUCooL (inkl. CPU Idle Manager) Version 5.2 nur Win9x+NT // Version 8.1.0 für Win2000/XP/Vista_32/Win7 (32 u. 64 Bit)
    HWMonitor (WinNT, 2000, ME, XP usw. jedoch nur bis Win8...)


    Hardwareinfo:
    WCPUID (Win95 bis XP)
    CPU-Z (ältere Versionen auch unter Win98, neueste Version unterstützt alle akt. Windows)
    GPU-Z (ab WinXP bis alle akt. Windows)


    CPU Stabilitätstests/Benchmarks:
    CPU Stability Test 6.0 (Win9x, kein XP)
    CPUburn (Win95 bis WinXP)
    Prime95 (Win95 bis aktuell)
    SuperPI (alte Version ab WinXP, neueste Version unterstützt akt. Windows)


    GPU Stabilitätstest/Benchmarks:
    FurMark (OpenGL2.0; auf Retro-PCs nutze ich 1.8.5 und 1.9.1)
    AquaMark (2.1=DX8, 3.0=DX9)
    3DMark (99=DX6, 2000=DX7, 2001SE=DX8, 03=DX9, 05=PS2.0, 06=PS3.0)


    Systeminfo mit CPU und RAM Benchmark:
    Dr. Hardware 2001 (Win95/98/Me und NT/2000)
    SiSoft Sandra 2004 Pro (WinXP, "Sandra 2000" für Win9x)
    AIDA32 bzw. dessen Nachfolger EVEREST Home Edition (ab WinXP)


    P.S.: Ich habe die Programme von alt nach neu sortiert, nicht nach Beliebtheit bei mir...

    "Ich habe einen Penis! Und ich werde ihn benutzen..." ~Gronkh

  • Kein Reboot

    Ok, Netzteil kann dann ja auch geschlossen werden. Dann kann es eigentlich nur noch an:

    • Bios Einstellungen
    • Windows ACPI Einstellungen
    • oder Hardware Defekt am Mainboard

    liegen.


    USB CD/DVD Rom


    Also mein externes Laufwerk hat so ein Art Y-Kabel (3 Stecker), ich denke dass ist dafür gedacht das Laufwerk an "alte" Mainbaords anzuschließen, also welche nur USB 1.1/1.0 bereitstellen. Für ausreichende Spannung müssen hier 2 USB Stecker in das Mainboard gesteckt werden.
    Da bei dir Fehler auftreten bei Verwendung eines längeren Kabels (größere Widerstand) mit nur 2 Steckern, klingt das danach als wenn das Mobo nur USB 1.1 kann ?(
    Alternativ haben diese USB Laufwerke manchmal noch ein zusätzliches Netzteil, dann entfällt das "Y-Kabel".

    Die Pixel beschleunigt, die Kanten gefixt, lang leben die Karten von 3dfx! :spitze:

  • //Edit:

    Was nutzt ihr so für Stabilitätstests, insbesondere RAM/CPU?

    [...]


    P.S.: Ich habe die Programme von alt nach neu sortiert, nicht nach Beliebtheit bei mir...

    thx!

    Also das Board hat definitiv USB2.0, daher bin ich über das Verhalten etwas verwundert - ich werde beizeiten mal ein anderes Laufwerk testen.

    Voodoo²
    Elsa Victory II (Voodoo Banshee)
    Voodoo 3 3500
    Voodoo 4 4500 PCI
    Voodoo 5 5500 AGP
    :gadget:


    Aus dem Chaos sprach eine Stimme zu mir und sagte: "Lächle und sei froh, es könnte schlimmer kommen", und ich lächelte und ward froh und es kam schlimmer.

  • ...

    AIDA32 bzw. dessen Nachfolger EVEREST Home Edition (ab WinXP)


    P.S.: Ich habe die Programme von alt nach neu sortiert, nicht nach Beliebtheit bei mir...

    Everest Home Edition ab xp? da kann ich dich einen besseren belehren!

    Habe Everest Home 2.20.405 und die läuft unter win98se!

    Ob es unter der ersten win98 Edition läuft, kann ich nicht sagen, hab es nie getestet!


    Hier downloadbar:

    http://www.oldversion.com.de/w…est-home-edition-2-20-405


    Kannst ja mal testen und deinen Softwarebestand erweitern.

    Bei mir gibt`s keine Probleme mit dieser Version.

  • AIDA64 ist auf sämtlichen Microsoft-Betriebssystemen (32 und 64 Bit) ab Windows 95 lauffähig.

    Das hier ist Version 2.0.1700.0 von 2011, weil ich die aktuelle Version auf meinem Win95 - System nicht mehr gestartet bekomme (hängt beim Startbildschirm "Lade Daten...").


    EDIT: Nach einer gefühlten halben Stunde Leerlauf (In Wahrheit ca. 10 Minuten; steht ja im Screenshot bei Laufzeit) ist dann doch noch die ganz aktuelle AIDA64 aufgegangen. Ich kann Wikipedia also bestätigen.