BIOS Problem Epox 7KXA

  • Moin zusammen,


    ich brauch nochmal eure Hilfe, bin mir nicht schlüssig obs ein Hard- oder Softwareproblem ist daher hab ichs mal in "Werkstatt" gepostet.

    Ich wollte das BIOS auf meinem Epox 7KXA updaten, das was drauf ist hat noch das Problem, dass es AGP4x automatisch aktiviert, auch wenn ne AGP2x Karte gesteckt ist. So funktionieren richtig alte Karten zwar, meine Rage Fury Maxx zB aber nicht.

    Problem ist nur, ich bekomm kein BIOS Update hin :P

    Versucht habe ich schon:

    - flashen über das eingebaute Tool (beim Start Alt+F2 drücken), ist ADWFLASH 7.22, da kommt immer die Meldung "unknown flash type"

    - ältere Version von AWDFLASH (6. irgendwas), selbes Verhalten

    - Uniflash: da scheint der Flashvorgang zu starten, ist aber fehlerhaft (rote Abschnitte im Fortschrittsbalken)

    - Hotflash per Uniflash mit mehreren anderen BIOS Chips verschiedener Hersteller (original ist ein Winbond W29C020-12) und einem neuen, extra gekauften Chip (Winbond W29C020C-90B, laut Datenblatt praktisch identisch zum original verbauten)


    Nix hat bisher zum Erfolg geführt. BIOS Image hatte ich zuerst von soggi.org, dann aber testweise auch nochmal woanders herunter geladen um auszuschließen dass das einen weg hat. Habe auch mehrere Disketten probiert, um das auch ausschließen zu können, die Fehler kommen immer identisch. Einziger Unterschied ist, wenn ich einen BIOS Chip eines anderen Herstellers verwende, steigt Uniflash komplett aus, dieser betreffende Chip scheint also generell entweder kaputt oder inkompatibel zu sein.


    Was könnte man noch versuchen? Habe vor dem flashen immer das BIOS auf "Safe Defaults" gesetzt und nur das Diskettenlaufwerk wieder aktiviert, sonst keinerlei Änderungen. Ein "write protect" fürs BIOS habe ich nicht gefunden.

    Voodoo: Athlon XP-2600+ auf Epox 8K5A2+, 512MB DDR, Voodoo 5 5500 AGP, SB Audigy Platinum EX, Win98SE+Win2000
    Voodoo²: Athlon XP-1800+ auf MSI K7T266Pro, 512MB DDR, ATI Rage Fury MAXX und Voodoo 2 SLI, Terratec DMX6-fire, Win98SE
    Kaputt im Schrank: 2x PIII-S 1,4GHz auf MSI Pro266TD Master

    Mainsys: I7-4820k auf Asus P9X79, 32GB DDR3, Vega56, Win10

    Midrange: 2x Xeon 3,2GHz Dell Precision 450, 3GB DDR, ATI HD3850 AGP, SB Live! mit LiveDrive, WinXP

  • Ja sind mir bekannt. Das "Black Screen" Problem mit der Maxx ist genau der Auslöser warum ich updaten will, im Changelog ist beschrieben dass frühere BIOS Versionenn vom 7KXA das Problem haben, mit aktiviertem AGP4x zu starten.

    Und Uniflash hatte ich ja auch probiert, sowohl mit dem origialen als auch mit diversen anderen BIOS Chips.

    Voodoo: Athlon XP-2600+ auf Epox 8K5A2+, 512MB DDR, Voodoo 5 5500 AGP, SB Audigy Platinum EX, Win98SE+Win2000
    Voodoo²: Athlon XP-1800+ auf MSI K7T266Pro, 512MB DDR, ATI Rage Fury MAXX und Voodoo 2 SLI, Terratec DMX6-fire, Win98SE
    Kaputt im Schrank: 2x PIII-S 1,4GHz auf MSI Pro266TD Master

    Mainsys: I7-4820k auf Asus P9X79, 32GB DDR3, Vega56, Win10

    Midrange: 2x Xeon 3,2GHz Dell Precision 450, 3GB DDR, ATI HD3850 AGP, SB Live! mit LiveDrive, WinXP

  • Ich verstehe die Aussage von ATi so, wenn die Lot Number 903046 ist oder darunter, dann ist die MAXX einfach inkompatibel mit dem Board. Die Nummer müsste sich auf einem Aufkleber in Nähe des ISA Slots befinden.

    Mein Board hat eine niedrigere Nummer und deswegen habe ich auch nicht mehr versucht zu flashen, denn mein BIOS ist vom Mai 2000 und dort sollte der "S3 Fix" schon enthalten sein laut Changelog.


    Den Tipp dass man die IDE Geräte abklemmt bei einem Flash-Vorgang hast du schon probiert? Ich hatte das wie gesagt nicht mehr geprüft. Kann mir das eigentlich auch nicht vorstellen aber ein Versuch ist es auf jeden Fall wert, geht schnell und tut nicht weh. ;)

    Die Pixel beschleunigt, die Kanten gefixt, lang leben die Karten von 3dfx! :spitze:

  • Als ich das letzte Mal ein altes Mainboard mit einem neuen BIOS versehen habe (ich bastel nicht unbedingt viel mehr an alter HW rum), musste ich die Flash-Protection ausschalten.

    Ich meine, da auch dieser Fehler kam...oder so ähnlich.

  • Grad mal in meinem Bios-Archiv nachgesehen. Habe zum letzten Bios für das Board 2 Ordner. Einmal nur die .bin Datei (kommt von soggi) und einmal wo Flasher, Biosfile und mehr drin sind (original von EPoX gezogen). Da fällt mir auf, dass es noch zusätzlich eine UPDATE.bat Datei gibt, die später datiert ist als das Bios. Vielleicht ist das essenziell wichtig in dieser Konstellation. :/


    Die Pixel beschleunigt, die Kanten gefixt, lang leben die Karten von 3dfx! :spitze:

  • Das könnte ich natürlich machen.


    UPDATE.BAT:

    RESTORE.BAT:

    Edit: Die README.txt dann auch noch

    Die Pixel beschleunigt, die Kanten gefixt, lang leben die Karten von 3dfx! :spitze:

    Edited once, last by Avenger ().