Voodoo5 5500 AGP und VIA KX-133

  • Hallo zusammen,


    ich bin mit meinem Latein am Ende und benötige professionelle Unterstützung.


    Hardware:

    Mainboard: EPOX 7KXA Slot A Rev 0.3 (kompl. Recap)

    CPU: Athlon 950 (Orion) / Athlon 800 (Pluto)

    Grafikkarte: V5 5500 AGP (+Matrox m3D)

    RAM: 512MB (1 Riegel)


    Software:

    BS: Win 98SE / SP3

    Treiber Board: VIA 4in1 4.43

    Treiber Grafikkarte: Evolution 1.01.16 / Amigamerlin 2.9 / 3Dfx 1.04.01

    DirectX: 7.0a / 8.1


    Toolbox: AGP 1x, V-Sync: off, VIA: Performance

    BIOS: AGP Fastwrite: off, AGP 4x: off, AGP Aperture: 4MB, VGA BIOS Cache/Shadow: off


    Das Problem: Die Performance ist schlecht und inkonsistent


    Mein Spitzenwert mit 3DM2000 lag bei 4089 3DMarks / 230 CPU Marks (TnL Emulation aktiv). Aktuell liegt er bei 3830 / 218. Beide Werte wurden mit den selben Toolbox- und BIOS Einstellungen (optimiert) und der selben Systemkonfiguration erzielt, das Einzige, was dazwischen lag, waren ein paar Neustarts. Wenn ich die TnL Emulation abschalte, liegt der CPU-Wert etwa 30 Punkte niedriger und der Gesamtwert 300 Punkte niedriger. Das Eigenartige, mit dem Athlon 800 ändern sich die CPU Marks nicht und der 3D Mark auch nur sehr wenig.


    Ich habe Windows nun 20 mal neu installiert ohne Besserung. Sämtliche Optimierungen in der Toolbox und dem BIOS habe ich auch schon durchgespielt. Die schlechtesten stabilen und optimierten Werte, die ich hatte (in einer anderen Windowsinstallation), waren 140 CPU Marks mit der V5, das schafft auch ein PIII 450. Das frustrierende: wenn ich eine G400 installiere, schafft der 800er Athlon 218 und der 950er 240 CPU Marks, die CPUs skalieren also ganz normal und das ohne TnL Optimierungen. Die V5 liegt bei dieser Konfiguration bei um die 185 CPU-Marks mit beiden CPUs. Q3A kommt mit den niedrigsten Einstellungen auch nicht über 90fps (mit dem 950er Athlon).

    Der Wechsel der DirectX Version bringt keine Änderung. Ich habe langsam das Gefühl hier blockiert irgend eine Treiberkombination VIA vs. 3Dfx und fügt sinnlose Waitstates ein. Der 4in1 4.35 zeigt das selbe Verhalten. Der KX-133 und die V5 scheinen nicht die besten Freunde zu sein.

    Ich dachte eigentlich dass ein schneller SlotA ein schöner Unterbau für die V5 wäre.


    Hat noch jemand einen Tip?


    Vielen Dank und viele Grüße

    Lutz


    Edit: das System läuft ansonsten super stabil, 24h Prime95 und Memtest ohne Fehler sowie 6h (hab dann abgesprochen) 3DM2000 im Loop. Die V5 kommt frisch von Backfire aus der Revision, die war und ist ok!

  • Die Werte sehe ich eher als Indikation für ein Treiberproblem. Wenn alles gut läuft, sollten um die 4300 Punkte rauskommen.
    Ich frage mich folgendes:


    1. Warum skaliert die V5 nicht mit der CPU bei mir, so wie es die G400 macht
    2. Warum bekomme ich jetzt konstant nur noch 5% niedrigere Werte als mein Spitzenwert? Egal, was ich mache.
    3. Warum ist die G400 (eine TNT2 liefert übrigens die selben Werte wie die G400) schneller im CPU-Mark und das ohne die TnL Emulation der V5?
    4. Warum ist die G400 bei Q3A lowest deutlich schneller als die V5?


    Die V5 bzw. deren Treiber scheint hier nicht mit dem System zu harmonieren und die CPU auszubremsen. Obwohl beide zeitgemäß super zusammenpassen.


    Ich habe alle verfügbaren V5 Treiber durchdekliniert, ohne Erfolg. Soll ich einen anderen 4in1 nehmen? Wenn ja welchen?


    Nochmal danke!

  • T&L braucht schon Leistung. Und wie soll die V5 da irgendwas dazu beistellen?
    Keine 3DFx Karte kann T&L in Hardware.. das läuft immer über die CPU. Was stellst du denn da ein/ aus?

  • Moin Lutz, erstmal wilkommen im Forum.


    Ich finde die Werte jetzt auch nicht so extrem schlecht und wenn es Differenzen gibt, dann würde ich mit einem Benchmark (Timedemo) aus einem Spiel gegen messen. Wir machen das meist mit UT99.


    Hier habe ich mal ein altes 3DMark2000 Ergebnis von meinem Slot A System gefunden:

    4265 | 16 Bit | V5 5500 AGP | Athlon 1000 (Orion) | AMD750 Irongate | Win98SE | Amigamerlin v2.9 (TnL on)| Avenger


    [Screenshot]


    Super Bypass ebenfalls aktiviert.


    Also wenn du UT99 zur Verfügung hast, dann kannst du die Timedemo von 3D Center [Download] verwenden und mit den Ergebnissen hier im Forum vergleichen.

    Zum Beispiel in meiner alten Benchsession: 3dfx Voodoo 3/4/5 [AGP/PCI] UT99 Benchsession


    Soll ich einen anderen 4in1 nehmen? Wenn ja welchen?

    Ja das würde ich auf jeden Fall mal probieren, ich meine das ein älterer besser war für VIA KT/KX133. Aus der Erinnerung würde ich 4.35 sagen.


    Nur zur Info: Windows 98 mag es gar nicht wenn man oft Treiber und unterschiedliche Geräte, in diesem Fall Grafikkarten, wechselt. Wenn ich das mal gemacht hatte in der Vergangenheit, dann hatte ich auch häufig die unterschiedlichsten Werte in diversen Benchmarks. Klingt blöd aber da half nur eine Neuinstallation. Hast du ja auch schon gemacht wenn ich das richtig verstanden habe aber ich wollte es trotzdem erwähnen.

    Die Pixel beschleunigt, die Kanten gefixt, lang leben die Karten von 3dfx! :spitze:

  • Vielen Dank für die Hinweise. Ich mache mal (wieder) eine Neuinstallation und werde dann die UT Benches nachliefern. Die aktuellen Werte von 3800 sind schon etwas niedrig für einen 950er Athlon.


    Ich habe von einem gelesen mit einem 950er Thunderbird auf einem KT133 mit 4500 Punkten - und das war 2001 mit Treibern von 2001. der KT133 ist nur minimal anders als der KX133. Das sind 11% mehr als mein (einmaliger) Maximalwert mit Amigamerlin 2.9 und 18% mehr als der Wert, den ich jetzt aus dem System herausgekitzelt bekomme. Der hier hat 3500 Punkte Anfang 2000 aus einem Athlon 700 bekommen.


    Wie auch immer, hier gibt es ein Problem und ich würde es gerne lösen :)

  • Ich habe mit einem 1000er TBird über 5500 Punkte geschafft.

    Der extrem niedrige Wert liegt wohl eher am aktiven Vsync. Den muss man im OC-Tab der 3dfx Tools zum Deaktivieren aktivieren. Ist nen nie behobener Fehler.

    4500 Punkte mit nem TBird sind grottenschlecht, zumal unter Win9x.

    Die Aperature Size würde ich auf 128 MB setzen. Das ist nämlich sinnvoll, weil der Voodoo schnell der Speicher ausgehen kann. Dann kann man einen Teil des RAMs dazu benutzen.

    T&L braucht schon Leistung. Und wie soll die V5 da irgendwas dazu beistellen?
    Keine 3DFx Karte kann T&L in Hardware.. das läuft immer über die CPU. Was stellst du denn da ein/ aus?

    Damit bekommt man kostenlos Punkte. Manche Spiele profitieren auch davon.

    „Wir leben in einer Welt, wo Ehrlichkeit als Schwäche zählt und die Lügner auf Händen getragen werden.“

    Edited once, last by CryptonNite ().

  • Mir war es damals nur durch dieses Feature möglich, das Spiel "Project Nomads" auf der Voodoo 5 zu spielen. Das setzte nämlich zwingend T&L voraus. War die T&L Softwareimplementierung von 3dfx nicht sogar SSE-optimiert (Pentium III, Athlon XP)? Aber da kann ich irren, da spielt mir meine neblige Erinnerung vielleicht schon einen Streich.

    1-6000-banner-88x31-jpg

    Stolzer Besitzer eines 3dfx Voodoo5 6000 AGP Prototypen:

    • 3dfx Voodoo5 6000 AGP HiNT Rev.A-3700 (defekt)

    [//wp.xin.at] - No RISC, no fun!

    QotY: Girls Love, BEST Love; 2018 - Lo and behold, for it is the third Coming; The third great Year of Yuri, citric as it may be! Edit: 2019 wasn't too bad either... Edit: 2020... holy crap, we're on a roll here~♡!

    Quote Bier.jpg@IRC 2020: "Je schlimmer der Fetisch, desto besser!"

  • Mein Spitzenwert mit 3DM2000 lag bei 4089 3DMarks / 230 CPU Marks (TnL Emulation aktiv).

    Da erreiche ich ja mit einem K6-2+/570ACZ@600 + GeForce2 TI mehr: 4102 3DMarks. ;)

    CPU Marks hab ich damals nicht nachgeschaut.


    War die T&L Softwareimplementierung von 3dfx nicht sogar SSE-optimiert (Pentium III, Athlon XP)?

    Weiß ich jetzt auch nicht mehr so genau, aber sie benötigt auf alle Fälle MMX+ (<- Plus!), das erst ab P-III bzw. Athlon zur Verfügung steht.



    Mal zurück zum Problem:

    Ich kenne Board und Chipsatz jetzt nicht wirklich und hab nur mal schnell ein paar Seiten dazu überflogen. Grundtenor ist, daß es ziemlich wählerisch beim RAM ist. Dein 512 MiB Riegel ist für SD-RAM mit der Kapazität auch heute noch eher ein Exot und nicht alle entsprechen dem JEDEC-Standard.

    https://www.heise.de/ct/artike…M-fuer-wenige-285136.html

    https://www.heise.de/ct/Redakt…er.html#Chipkombinationen (Fußnoten beachten)


    Fangen wir also mal beim Fundament an:


    :?:Bist Du sicher, daß der auch mit 100 bzw. 133 MHz getaktet wird (soweit ich es verstanden habe, beherrscht der Chipsatz einen asynchronen CPU-RAM-Takt) und nicht nur mit 66 MHz?


    :?:Das neueste BIOS ist installiert?

    Ich werde mich von keinem einzzzigen Prozzzessor trennen.
    Jedoch lockt es mich beinahe, ihn Dir zu überlassen, nur um zu sehen, wie er Dich in den Wahnsinn treibt :evil:


    Meine Begehren

  • Also der VSync ist definitiv deaktiviert, darum hatte ich mich auch gleich gekümmert. Man kann es auch gut an den realen FPS erkennen, die teilweise deutlich oberhalb der Monitorfrequenz liegen.


    Gerade der CPU Mark ist ein gute Indikator, dass hier was nicht stimmen kann, außerdem wunderbar reproduzierbar. Mit einer G400 bzw. TNT2 komme ich auf über 240 Punkte, die V5 schafft schlappe 185 Punkte, jeweils mit Athlon-Optimierungen. Mit dem TnL Bonus schafft die V5 nochmal 30 Punkte mehr, ist aber immer noch weit entfernt von den anderen beiden Karten.


    Der RAM läuft super, auch schön stabil. Das konnte ich mit der G400 schön austesten. Wenn ich die CL von 3 auf 2 stelle, gibts verbesserungen und auch wenn ich den Takt von 100 auf 133 stelle. Ich werde mal mit einem 256er Riegel probieren, ob sich etwas ändert. Das BIOS ist aktuell.


    Edit: der RAM ist es nicht, habe gerade mit einem doppelseitigem 256er getestet, der auch im i440BX läuft.


    Ich werde das System nächste Woche nochmal neu aufsetzen und nehme mal einen älteren VIA Treiber - vielleicht den 4.29. Welchen 3DFx Treiber würdet ihr empfehlen? Den 1.04.01 - da bietet mir die Toolbox in den D3D Features keine VSync Option an, bei Overclocking gibts das Kästchen, aber reicht das? - oder den Evolution 1.01.16 - der bietet alle Features in der Toolbox.

  • Welchen 3DFx Treiber würdet ihr empfehlen? Den 1.04.01 - da bietet mir die Toolbox in den D3D Features keine VSync Option an, bei Overclocking gibts das Kästchen, aber reicht das?

    Wenn du nur alte Spiele mit dem System verwenden möchtest, dann ist der Treiber in Ordnung. Die späteren Treiber bringen eigentlich nur was wenn man neuere Spiele spielen will.

    Im OC Tab, wenn dort ein Haken bei Vsyn OpenGL | Direct3D gesetzt ist, dann ist Vsync deaktiviert. Wie von CryptonNite oben schon beschrieben, ein Fehler oder man könnte auch von einem Paradoxon sprechen.


    Als Hinweis: Du kannst auch das zusätzliche Tool V.Control verwenden. Dort findest du auch sämtliche Einstellungen. Einige User hier nutzen das lieber als die original 3dfx Tools.

    Die Pixel beschleunigt, die Kanten gefixt, lang leben die Karten von 3dfx! :spitze:

  • Ich hab das selbe Board mit einem 800er Pluto. Meine Ergebnisse müssen hier auch noch irgendwo sein. Könnte man ja mal vergleichen.

    Ich war zufrieden aber spektakulär war die Punktzahl auch nicht. Hauptsache die Spiele laufen :D

  • Hmm nice build as the AMD 751 Irongate /756 Viper Chipset my MSI MS6195 K7 Pro uses it really didn't like me using Matrox G400, G400 MAX or even a G550 in it, but with a 3dfx Voodoo3 3500 in it, it runs just fine.
    You can read about my Slot A Build here and hey she does fly well tho!
    Nighthawk, my AMD 750 Slot A build!

    Seeing that this build uses a VIA VX133 chipset I am hoping you will get more luck with this build.
    Would be interesting to see how a V5 5500 AGP would do in a build like this despite it being very under powered for that card, an AthlonXP 2000+ or higher is what I would recommend for that card, but yea interesting for sure, keep us posted man :)

    As drivers go AmigaMerlin 2.9 can be great but you can also give the ThunderGL drivers a go, otherwise the drivers from Raziel64 :)

  • vielleicht mal noch als Ergänzung und zur Einordnung..


    Ich habe in 3DM 2000 mit einem P3 1000/100 430+ CPU Marks ...


    edit:


    Ich hab die V5 eben nochmal eingebaut und laufen lassen.
    Ohne T&L Feature im Treiber hab ich 4730 Punkte bei 433 CPU Punkten.

    Mit T&L Feature im Treiber hab ich 4103 Punkte bei 227 CPU Punkte.


    Also zumindest für den Pentium 3 und für den Benchmark ist das Feature murks.

  • Und nochmal danke für Eure Tips und Unterstützung. Karre erstmal herzlichen Glückwunsch zu der CPU - Slot1? 8) Die Tests sind tatsächlich ganz spannend. Meine Werte wirken in diesem Kontext gar nicht mal so schlecht. Der 3DM2000 scheint sehr von SSE zu profitieren.


    Ich habe mal in Kaitous Benchmarkthread nachgeschaut und zwei interessante Werte gefunden.

    • 4265 | 16 Bit | Avenger | V5 5500 AGP | Athlon 1000 (Orion) | AMD750 Irongate | Win98SE | Amigamerlin v2.9 (TnL on)
    • 3423 | 16bit | 1986richie | 3dfx Voodoo5 5500 | AMD Athlon Slot A 1000MHz | KX133 | WinXP | AmigaMerlin 2.9

    Ich bin scheinbar nicht der Einzige mit einer KX133/V5 Kombi und solchen Auffälligkeiten. Der Irongate performt besser bzw. stabiler.


    Ich hab wie versprochen Windows nochmal platt gemacht und frisch installiert: Win98SE + VIA 4in1 4.35 + 3Dfx 1.04.01 + DirectX 7.0a + 3DM2000 - in der Reihenfolge und nix weiter. Jetzt passen die Werte wieder besser, vor allem auch im Vergleich zu Avenger ´s und Karre ´s Werten.


    • 4197 | 16 Bit | Hoom | V5 5500 AGP | Athlon 950 (Orion) | VIA KX-133 | Win98SE | 3Dfx 1.04.01 (TnL on) | 235 CPU-Marks

    Bzw.


    3528 / 191 - 3DNow! Optimierungen

    3821 / 211 - Athlon Optimierungen


    Also SSE scheint hier 3DNow! ziemlich überlegen ;)


    Der Wert war vorher im selben System in der selben Konfiguration bei 3830 für TnL Optimierungen.
    Jetzt werde ich die übrigen Treiber und Patches installieren und schauen, welcher dieser SW-Komponenten die Probleme verursacht. Ich war schon kurz davor, auf ein S462 oder S370 System zu wechseln, dabei freue ich mich riesig über den schicken Orion.


    Nochmals vielen Dank für die Unterstützung und Hilfe!


    Edit: UT99 werde ich noch nachliefern!


    Edit: Der VIA scheint tatsächlich nicht der beste Freund der V5 zu sein, zumindest nicht die Produkte mit SDRAM der Jahre 2000/2001

    • 6625 | 16bit | rockys82 | 3dfx Voodoo5 5500@185MHz | P3-S-King@~1470MHz@Slot1 | I440BX@140MHz| Win98SE | AmigaMerlin 2.9
    • 4576 | 16bit | rockys82 | 3dfx Voodoo5 5500@183MHz | 2x P3-S@~1500MHz | VIA Apollo PRO 133T | WinXP, SP3 | AmigaMerlin 3.1-R11
  • Nee, das liegt eher am verwendeten Windows XP. Das ist immer langsamer.

    „Wir leben in einer Welt, wo Ehrlichkeit als Schwäche zählt und die Lügner auf Händen getragen werden.“

  • Also ich konnte die Netzwerkkarte von 3Com als Übeltäter entlarven. Ich habe drei verschiene Revision von dieser ausprobiert, jede hatte diese Auswirkungen. Mit einer Intel Netzwerkkarte läufts jetzt besser.


    Im 3DM2000 komme ich sogar noch etwas höher:

    • 4291 | 238 CPU-Marks (TnL Optimierungen)

    Allerdings dann ohne Soundkarte und minimaler Installation. Mit voller Ausstattung und dreifachem Loop sieht es dann so aus

    • 4248 | 235 CPU-Marks (TnL Optimierungen)


    Avenger

    Die UT99 Benches habe ich ebenfalls nachgeholt:

    640x480x16 FPS (min/avg/max):

    • Utbench: 23,59 / 39,51 / 57,95
    • Benchmark: 42,45 / 80,56 / 145,81

    1024x768x16 FPS (min/avg/max)

    • Utbench: 18,92 / 37,68 / 51,55
    • Benchmark: 41,17 / 74,51 / 132,18


    Diese Werte passen sehr gut zu Deinen, scheint tatsächlich alles schick zu sein. :)