Der 10,- € Windows XP Gaming PC - Wyse Thin Client 5010 und 7010

  • Also irgendwas stimmt mit der GPU nicht. In 3DMark2001SE bekomme ich 9526 Punkte, also maginal mehr als mit der kleineren APU.

    Ich habe einige Slowdowns und der GPU-Takt pendelt die ganze Zeit zwischen 275 und 600 MHz. Kann man den irgendwie fixieren?

  • Hm, ich habe den GPU Takt nie beobachtet.

    Wie heiß wird der HP? Erreicht er auch 90°C?
    Es kann gut sein, dass sich die TDPs stark unterscheiden.

    Come to the dark side, we have cookies!

  • Neue WLP und da liegt ein Lüfter auf dem Kühler, GPU liegt konstant unter 40 °C. Temperatur ist kein Problem.

    Jetzt habe ich den GPU-Takt auf 600 MHz fixiert, zumindest sagen das die Tools. Leider keine Verbesserung.
    Wenn ich den Takt (vermeintlich) auf 300 MHz fixiere, bekomme ich ähnliche Ergebnisse. Bei 100 MHz auch so. Also ist das alles nur Kosmetik :(

    Beim x264_Benchmark habe ich 0 Probleme. Da bin ich auf das Prozent so schnell wie andere G-T56N.

  • HP T610 (Plus) Thin Client als Windows XP Retro-PC

    Ich wollte euch meinen kleinen Zoo an T610 einmal vorstellen, den ich für den spontanen Retro-LAN-Einsatz gebaut habe.
    Insgesamt sind es 4+2. Vier normale T610 und zwei T610 Plus mit einer Radeon HD 7750.

    In Anlehnung an den ersten Post von RaVeNsClaw hier einmal analog.

    Hardware Details

    Display Spoiler
    • CPU: AMD Fusion G-T56N (2x 1.65 GHz)
    • iGPU: AMD Radeon HD 6320 (512 MB zugeteilt, 508..600 MHz (iGPU), 80/8/4/2 (Shader/TMU/ROP/CU)
    • GPU: AMD Radeon HD 7750 (1 GB GDDR5, 800/1.125 MHz (GPU/RAM), 512/32/16/8 (Shader/TMU/ROP/CU) (T610 Plus only)
    • RAM: 4 GB DDR3-1333 9-9-9-24-33-1T
    • Schnittstellen:
      • Intern: 2x SATA, 1x IDE44, 1x Mini-PCIe x1, 1x PCIe x4 (T610 Plus: Riser auf PCIe x16), 1x Lüfter (keine Standardbelegung, s. Bilder)
      • Extern: 1x DVI, 1x DisplayPort, 1x RJ45, 4x USB 2.0 (2x Frontseite, 2x Rückseite), 2x USB 3.0, 2x 3,5 mm Audio (Mikrofon/Kopfhörer, Frontseite), 1x RS232, 2x PS/2 (Maus/Tastatur), (T610 only: + 1x RS232, 1x LPT)
    • Netzteil:
      • T610: 65 W (19,5 V / 3,3 A)
      • T610 Plus: 85 W (19,5 V / 4,36 A)
    • Stromverbrauch:
      • T610: 12 / 23 / 29 W (Idle/Gaming/Max. Load*)
      • T610 Plus: 21 / 43 / 64 W (Idle/Gaming/Max. Load*)
    • Maße:
      • T610: 22 x 24 x 4 cm (BxHxT)
      • T610 Plus: 22 x 24 x 6,5 cm (BxHxT)
      • Jeweils ohne Standfuß

    * = Prime95 & FurMark

    Performance

    Display Spoiler

    T610:

    • Quake III v1.32 Demo Four: 1280x1024, max. Details: 159 fps
    • UT99 City Intro: 1280x1024, max. Details: 50/129/77 fps (min/max/avg)
    • UT99 Benchmark.dem: 1280x1024, max. Details: 43/116/75 fps (min/max/avg)
    • 3DMark2001 SE: 9.526 Punkte
    • 3DMark03: 6.726 Punkte
    • 3DMark05: 4.356 Punkte
    • x264Benchmark: 17h 5m 20.140s

    T610 Plus mit AMD Radeon HD 7750:

    • Quake III v1.32 Demo Four: 1280x1024, max. Details: 204 fps
    • UT99 City Intro: 1280x1024, max. Details: 50/159/86 fps (min/max/avg)
    • UT99 Benchmark.dem: 1280x1024, max. Details: 47/173/87 fps (min/max/avg)
    • 3DMark2001 SE: 12.978 Punkte
    • 3DMark03: 21.618 Punkte
    • 3DMark05: 7.283 Punkte
    • x264Benchmark: s. T610

    Irgendwas scheint mit dem T610 nicht zu stimmen.

    Im Vergleich zum Wyse 7010 passen die fps bei Quake III, aber beim 3DMark2001 SE schlage ich den Wert gerade mal mit der Radeon HD 7750.
    Ich habe an einigen Stellen auf massive Einbrüche der Framerate, tlw. bis in den niedrigen einstelligen Bereich.
    Die installierten Spiele laufen alle annehmbar, nur Need for Speed Underground 2 ist etwas hungriger als gedacht.

    Falls hier jemand die rettenden Idee hat, was den T610 zurückhält, gerne melden.
    Power Management Optionen im BIOS sind alle deakvitiert und die iGPU bekomme ich mit Tools auch nicht unter Kontrolle.

    Wer sich die Frage stellt, ob es sich lohnt einen T610 Plus mit dezidierter GPU zu kaufen: Nein.
    Der Rechner ist nicht mehr lautlos, die Leistungsaufnahme verdoppelt sich fast und der Gewinn an Spielleistung ist dies in meinen Augen nicht wert.

    BIOS-Einstellungen

    Display Spoiler

    Das BIOS ist über F10 aufrufbar.

    Für eine einfachere Windows XP Installation habe ich den IDE-Mode anstatt AHCI verwendet.

    Storage >> Storage Options >> SATA Emulation >> IDE Mode

    Der T610 hat leider die Macke, dass die Zuweisung des RAM zur iGPU komisch ist.
    Ich habe insgesamt 4 GB RAM verbaut und kann nicht auf die gesamten 4 GB zugreifen, also insgesamt.

    Advanced >> Device Options >> Integrated Graphics >> Force


    Advanced >> Device Options >> Integrated Graphics >> UMA Frame buffer Size >> 512M

    Verteilung RAM

    System

    iGPU

    Auto

    2,48 GB

    384 MB

    256M

    2,73 GB

    256 MB

    512M

    2,48 GB

    512 MB

    1G

    1,98 GB

    1.024 MB

    Die Speichergrößen der iGPU habe ich GPU-Z entnommen.

    Ich habe dann 512 MB gewählt. Für den Einsatzzweck des Rechners ausreichend.

    Beim Einbau einer dezidierten GPU im T610 muss die iGPU deaktiviert werden.

    Advanced >> Device Options >> Integrated Graphics >> Disabled

    Wichtig: Immer mit F10 bestätigen. Ein Klick auf Esc verwirft die Änderungen.

    Treiber

    Display Spoiler

    Windows XP

    Display Spoiler

    Windows XP habe ich versucht so minimalistisch wie möglich zu konfigurieren, ohne aber ein eigenes Image dafür zu basteln.
    Installiert ist das neuste Service Pack 3 inkl. aller Updates, sowie .NET Framework 2.0, 3.5 und 4.0.

    Für das Deaktivieren von einigen Diensten nutze ich das Skript svc2kxp.cmd. (Link)

    Da ich Windows XP auf einer SSD installiert habe, sollte man die Defragmentierung noch deaktivieren. Bei einer SSD ist nicht mehr nützlich, sondern nur noch schädlich.
    Hierzu füge ich zwei Registry-Keys hinzu, die die Defragmentierung unterbinden.

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\OptimalLayout]
    "EnableAutoLayout"=dword:00000000

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Dfrg\BootOptimizeFunction]
    "Enable"="N"

    Hier als REG-Datei zum hinzufügen bzw. ändern: Link

    Bezugsmöglichkeiten

    Display Spoiler
    • T610: Piospartslap (Preisvorschlag mit 20 € wurde akzeptiert)
    • T610 Plus: eBay (ca. 36 €)
    • Standfuß: eBay (ca. 8 €)
      • Achtung: Die für 3 € angebotenen Standfüße bei Piospartslap sind leider nicht T610 kompatibel. Getestet und auch zurückgemeldet, aber die werden weiterhin angeboten. Also Finger weg davon!

    Bilder

    Edited 20 times, last by Chosen_One (February 25, 2024 at 3:54 PM).

  • Sehr schön! 8)
    HP hat also auch Versionen mit der APU und mit PCI-E Slot gemacht.
    Ich habe so ein Teil mit einem Turion X2, da hat das mehr Sinn gemacht. War aber elend laut. ;)

    Dafür sieht der SSD Einbau viel einfacher aus! :thumbup:

    Come to the dark side, we have cookies!

  • Ja, der SSD-Einbau ist recht einfach.

    Baut man die Elektronik aus dem SSD-Gehäuse sollte ein kleiner Klecks Heißkleber das Modul dauerhaft an Ort und Stelle halten.

    Wenn man die gesamte SSD verbauen will, muss man sich Gedanken machen, wie man diese stabilisiert.
    Da gibt es aber was aus dem 3D-Drucker, wer da Zugriff auf einen hat.

    Beispiel: https://www.thingiverse.com/thing:3528293

    Edited 2 times, last by Chosen_One (February 9, 2024 at 12:28 AM).

  • Moin zusammen!

    Habe mir nun auch einen 5010 als kleinen, leisen Retrocomputer zurechtgemacht.
    Konnte beim Aufrüsten zum Glück auf meinen Fundus an ausgebauten Einzelteilen zurückgreifen und der 5010 wurde in der Firma ausgemustert, weil die Geräte mit GBIC-NIC immer wieder für Probleme gesorgt haben.
    Dieser hat jetzt 4GB statt 2, eine 120GB SSD mit XP und W7 Dualboot und eben WLAN.

  • Wie ich sehe hast du einfach die SSD im 30° Winkel über die Metallpfosten und die IO Platine in den SATA Sockel gequetscht? Mit etwas Malerklebeband dazwischen? :topmodel:
    Uh, das tut mir in der Seele weh. :topmodel::topmodel::spitze:

    Come to the dark side, we have cookies!

  • Ist die Quick´n´Dirty-Lösung, konnte ich vom Gefühl grad noch so vertreten.
    Hätte auch das schon erwähnte SATA-Extenderkabel gehabt, spare ich mir für größere SSD-Platinen.
    Eventuell werden noch weitere 5010 "entsorgt". ;)

    Hat schon jemand den anderen SATA-Port testen können?

  • Meine 5010 aus 2 verschiedenen Quellen haben keinen zweiten SATA Port.
    Sind das wirklich 5010 bei dir? Da sind einige Unterschiede sichtbar.

    Come to the dark side, we have cookies!

  • Fujitsu Futro S720 (D3313-B1) Thin Client als Windows XP Retro-PC

    Ein weiterer Kandidat für einen Retro Thin Client auf Windows XP Basis.
    Neuere AMD APU mit mehr Leistung, die mit etwas mehr Aufwand bei der Einrichtung erkämpft werden muss.

    Hardware Details

    Display Spoiler
    • CPU: AMD Fusion GX-217GA (2x 1.65 GHz)
    • iGPU: AMD Radeon HD 8280E (512 MB zugeteilt, 450 MHz (iGPU), 128/8/4/2 (Shader/TMU/ROP/CU)
    • Mainboard: Fujitsu D3313-B1
    • RAM: 4 GB DDR3-1600 11-11-11-28-39 (1x SO-DIMM)
    • Schnittstellen:
      • Intern: 1x SATA, 1x mSATA, 1x USB 2.0, 1x SATA-PWR (5V only), PoE/LAN-Header (prorietär), TPM-Header
      • Extern: 1x DVI, 1x DisplayPort, 1x RJ45, 4x USB 2.0 (Rückseite), 2x USB 3.0 (Frontseite), 2x 3,5 mm Audio (Mikrofon/Kopfhörer, Frontseite), 2x 3,5 mm Audio (Line In/Out, Rückseite), 1x RS232, 2x PS/2 (Maus/Tastatur)
    • Netzteil: 40 W (20 V / 2 A)
    • Stromverbrauch: 5 / 16 / 17 W (Idle/Gaming/Max. Load*)
    • Maße: 18 x 25 x 5 cm (BxHxT) ohne Standfuß

    * = Prime95 & FurMark

    SSD-Einbau

    Display Spoiler

    Der S720 hat die Besonderheit, dass er einen mSATA-Port für MO-300 SSDs hat.
    Dieser ist sehr gut erreichbar und lässt sich bequem mit 128/256 GB SSDs bestücken, die man neu für 20-30 € bekommt.

    Möchte man eine 2,5" SSD nutzen, muss man ein wenig suchen und basteln.
    Unter dem Kühlkörper ist ein SATA-Port versteckt, wofür man im Idealfall ein 90°-gewinkeltes SATA-Kabel benötigt.
    Die Stromversorgung wird über einen Teil vom internen USB-Header realisiert. Der Header hat keine 2x USB 2.0 Funktionalität, sondern nur einfach.
    Der untere Teil hat 1x GND und 1x 5 V, worüber sich eine SSD betreiben lässt. 12 V werden für eine SSD nicht benötigt, die findet man auch nicht auf der Platine.

    Performance

    Display Spoiler
    • Quake III v1.32 Demo Four: 1280x1024, max. Details: 220 fps
    • UT99 City Intro: 1280x1024, max. Details: 62/165/92 fps (min/max/avg)
    • UT99 Benchmark.dem: 1280x1024, max. Details: 56/176/82 fps (min/max/avg)
    • 3DMark2001 SE: 13.056 Punkte
    • 3DMark03: 9.903 Punkte
    • x264Benchmark: 13h 0m 23.687s

    Die Einstellungen der Spiele waren 1:1 die vom T610 und hier macht der S720 noch einmal einen Leistungssprung im Vergleich zum T610 (Plus) und auch zum Wyse 7010.
    Damit dürfte der S720 sich gut in die Reihe der Windows XP Thin Clients einfügen.

    PCIe 2.0

    Display Spoiler

    Der Mini-PCIe x1 ist standardmäßig nur als PCIe 1.1 aktiviert. Hier stehen 2.5 GT/s als maximale Bandbreite zur Verfügung.
    Die Mainboards unterstützen jedoch PCIe 2.0. Leider gibt es im BIOS keine Einstellmöglichkeit.

    Mit dem Programm EditCMOS kann man die Variable 0x1b7 (FjSetupIdPsppPolicy, PCIe Speed Power Policy) aber einstellen.
    Standardmäßig sollte dort der Wert 0x152 gesetzt sein, mit 0x151 kann man auf PCIe 2.0 umschalten.

    Der Befehl zum ändern lautet: editcmos.exe setid:0x1b7=0x151

    Nun stehen 5 GT/s, also die doppelte Bandbreite, zur Verfügung.

    Wer eine WLAN-Karte o.ä. einbauen möchte, sollte dies aktivieren, um das Maximum aus der Karte herauszuholen.

    BIOS-Einstellungen

    Display Spoiler

    Das BIOS ist über DEL aufrufbar.

    Für eine einfachere Windows XP Installation habe ich den IDE-Mode anstatt AHCI verwendet.

    Advanced >> SATA Coinfiguration >> SATA Mode >> IDE

    Der S720 hat leider die gleiche Macke wie der HP 610, dass die Zuweisung des RAM zur iGPU komisch ist.
    Ich habe insgesamt 4 GB RAM verbaut und kann nicht auf die gesamten 4 GB zugreifen, also insgesamt.
    Genau wie beim T610 weise ich der iGPU 512 MB zu und das System hat noch ca. 2,5 GB zur Verfügung.

    Advanced >> IGD Memory >> 512M

    Treiber

    Display Spoiler

    Die Treiberinstallation verläuft etwas unsauberer als bei den AMD APU der Vorgängerserie.
    Offiziell gibt es keine Windows XP Treiber für die 1st Gen G-Serie (Kabini, Jaguar-basiert), jedoch läuft der Catalyst 14.4 Pack 3 (Pack 2 hat keinen Kabini-Support!) anstandlos durch und installiert alle AMD-relevanten Teile.
    Lediglich der ACPI-Treiber von Fujitsu muss hier noch manuell nachinstalliert werden. Das ist das "Unbekannte Gerät" im Gerätemaneger.

    Windows XP

    Display Spoiler

    Windows XP habe ich versucht so minimalistisch wie möglich zu konfigurieren, ohne aber ein eigenes Image dafür zu basteln.
    Installiert ist das neuste Service Pack 3 inkl. aller Updates, sowie .NET Framework 2.0, 3.5 und 4.0.

    Für das Deaktivieren von einigen Diensten nutze ich das Skript svc2kxp.cmd. (Link)

    Da ich Windows XP auf einer SSD installiert habe, sollte man die Defragmentierung noch deaktivieren. Bei einer SSD ist nicht mehr nützlich, sondern nur noch schädlich.
    Hierzu füge ich zwei Registry-Keys hinzu, die die Defragmentierung unterbinden.

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\OptimalLayout]
    "EnableAutoLayout"=dword:00000000

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Dfrg\BootOptimizeFunction]
    "Enable"="N"

    Hier als REG-Datei zum hinzufügen bzw. ändern: Link

    Bezugsmöglichkeiten

    Display Spoiler
    • Futro S720 (inkl. Netzteil & Standfuß): Piospartslap (Preisvorschlag von 18 € wurde akzeptiert)
    • MO-300 mSATA SSD 128-256 GB: Geizhals
    • WLAN-Modul (optional): eBay (Hinweis: Dadurch wird wohl der komplette Header belegt, der für die 2,5" SSD benötigt wird.)

    Bilder

    Edited 17 times, last by Chosen_One (March 30, 2024 at 2:35 PM).

  • Neuere AMD APU mit mehr Leistung, die mit etwas mehr Aufwand bei der Einrichtung erkämpft werden muss.

    Ooooh, das ist sehr interessant. Ich hatte hier im Thread ja schonmal den S920 (mit GA-415GX und 8330E) versucht und war am GPU Treiber gescheitert. Wärst du bereit dein XP Image zu Testzwecken zu teilen? Dann würde ich es mit dem S920 nochmals versuchen. Alternativ, du hast exakt die Treiber die du oben verlinkt hast am laufen?

    Wir haben die S920 vor einiger Zeit als Terminal Clients ausgemustert, deshalb habe ich mehrere hundert davon (!) zum Testen in der Hinterhand... :spitze:

    Unter dem Kühlkörper ist ein SATA-Port versteckt, wofür man zwingend ein 90°-gewinkeltes SATA-Kabel benötigt.

    Geht auch mit einem normalen Stecker, er passt durch die Kühlrippen durch und dann kann man oben drüber das Kabel 90° knicken. Geht einwandfrei bei mir. Für Strom gibts beim S920 eine Floppy Power Buchse, die ist bei dir unbestückt. Dort kann man auch 5V abgreifen. Die Lötaugen befinden sich genau unter dem "2.0" von deiner Beschriftung von "USB 2.0", rechts neben dem SO-DIMM Slot.

  • Image kann ich nicht erstellen, weil ich das nicht von der mSATA herunterbekomme. Da werde ich keine Anstrengungen unternehmen, sorry.

    Was die Treiber angeht, ja genau diese Pakete habe ich benutzt. Ich hatte mehrere Pakete, die ich probiert habe und mit den Verlinkten konnte ich alle Geräte versorgen.
    Das wichtigste Paket war der Catalyst 14.4. Auf der AMD-Seite bekommt man aber nur das Pack 2, nicht 3, wo es keinen Kabini-Support gibt. Dort waren im Grunde alle AMD-Treiber enthalten, die das Mainboard brauchte.

    Meine Sata-Kabel passten leider nicht durch die Kühlrippen, da gibt es sicherlich dünnere Stecker.
    Mit den 5 V hast du recht, ein Lötpunkt hat 5 V, zwei andere GND. Könnte man Stifte auflöten.
    Auf dem PCB gibt es FAN1 und FAN2, wo scheinbar in einer anderen Variante auch Lüfter angeschlossen werden können, aber Lötpunkte sind beim S720 leider nicht beschaltet.

    Wenn du einen S920 über hast, könnte ich mich parallel damit beschäftigen, was es braucht, um den XP-fähig zu bekommen.

  • Chosen_One

    Ich möchte dir Tiernamen geben... :topmodel: Der S920 rennt mit deinem Catalyst einwandfrei unter XP. BÄM! :love:

    Den im Vergleich zu deinem 720er etwas geringeren 3DM01 Score schiebe ich mal auf den Takt der Cpu, weil der Quad nur mit 1,5ghz rennt. Der Dualcore müsste 1,65ghz haben? Da frage ich mich nun, ob man die IGP und die CPU übertakten kann...


    Edited once, last by Dem_Olli (February 16, 2024 at 9:27 PM).

  • Freut mich zu hören, dass es läuft :)
    Overclocking ist leider aber nicht auf den SoC-Maschinen machbar.

    Nächste Stufe wäre ein Thin Client mit GX-420CA, also 4x 2.0 GHz und 8400E.
    Wurden verbaut in einigen Wyse (z.B. 7020, 7450, etc.), HP T620 Plus oder auf dem Fujitsu D3313-S3 Mainboard.

    Gibt es da einen Thin Client in der Region 30 €?

  • An der Stelle bin ich überfragt. Ich habe wie erwähnt aktuell guten Zugriff auf den S920, deshalb sind die anderen für mich eher uninteressant.

    Was übrigens Wlan angeht, da lohnt es sich den mPCIe Slot zu nutzen, weil dann der Pfosten für 2.5" SATA Strom frei bleibt. Oder alternativ kann man auch einen mPCIe Sata Controller und mehrere 2.5" SSDs verbauen... Bei mir schaut es als Bastelsetup aktuell so aus:

    • S920
    • XP SP3 mit dem erwähnten Fuji ACPI und Catalyst 14.4 Pack3 Treiber
    • 2x4gb DDR3-1600
    • 2gb oder 8gb mSATA SSD (ab Werk verbaut)
    • mPCIe Wifi Karte
    • 2.5" SATA SSD mit Stromadapter via Floppy Power Anschluss

    RaVeNsClaw Da sowohl der S720 als auch 920 nun mit XP laufen können die gerne mit in den Startpost.

    Ich habe noch einen 3DMark 05 nachgeschoben und komme auf 5600 Punkte: